rt2500 wifi problems - kde4.1 opensuse 11


I’m a bit of a newbie btw.

I installed opensuse last night and I have tried for over 5 hours to get my wifi to work and i cant.

I used this how-to for opensuse 10.3

10.3 & Rt2500 Wireless Howto - openSUSE Forums

it still doesnt work. knetwork manager now doesn’t recognise my wifi card. I can see my wifi card when i run ‘Network Settings’ in YaST and I can choose which driver to use.

I used to use rutilt but i tried to install that again from source and it says that i dont have gtk+ 2 but i do so i’m stuck there as well.

what can I do?

help would be greatly appreciated!!


Have you tried using the module supplied with opensuse11 for your card, rt2x00? Download the firmware from ralink for your card, place the firmware in /lib/firmware and load the module.

thanks for the reply,

what does the firmware look like?

how do i load the module? is it ‘modprobe rt2500’?


In my case, the modules were automatically loaded. They are located in /lib/modules/KERNEL-NAME/kernel/drivers/net/wireless/rt2x00/ directory. What you need to do is go to the ralink website, download the driver for your card, extract the firmware, place the firmware in /lib/firmware, and finally reload the module. Reload means unload then load and should work with a reboot.

i think that my driver works now. with root when I type iwconfig, it gives

ra0       RT2500 Wireless  ESSID:"2WIRE973"  Nickname:"2WIRE973"
          Mode:Managed  Frequency=2.437 GHz  Access Point: 00:12:88:32:A6:01
          Bit Rate=48 Mb/s   Tx-Power:0 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:3232-3333-3234-3734-3431-0000-00   Security mode:open
          Link Quality=63/100  Signal level:-66 dBm  Noise level:-80 dBm
          Rx invalid nwid:0  Rx invalid crypt:0Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0  Missed beacon:0

its doesn’t look like the encryption key is the right one. I still cant connect to the internet and knetworkmanager is rubbish and just doesn’t work and doesn’t pick up ra0!

what can i do?



On my computer I hooked up the card and installed Suse 11.0. I did a on line up date by connecting with a cable using the eth0. during the update it installed the filmware for the wifi. I then used yast to set it up. Been working fine.
Hope this helps.

which version of opensuse 11 did you use?

I used the kde 4.1 live cd.


How are you setting the ip address and default router? From the post it looks like you are associated just fine. Now you need to give your interface an ip address and set the routing table. Try using ‘dhclient ra0’, that should provide both when the router provides DHCP. If not, you need to manually set the ip address and configure resolv.conf, perhaps setting a default router with ‘route’.

knetworkmanager fails to see the interface at all? What interfaces are shown there?

thanks for the reply David!

I didn’t understand much of what you said, it went over my head.

I ran ‘dhclient ra0’ and it gave this

Listening on LPF/ra0/00:11:50:66:9f:2f
Sending on   LPF/ra0/00:11:50:66:9f:2f
Sending on   Socket/fallback
DHCPREQUEST on ra0 to port 67
bound to -- renewal in 37778 seconds.

does that mean i’ve been allocated an ip adress? what do i do now? i’m a noob :frowning:

thanks for the help i appreciate you giving up some of your time to help me! :slight_smile:


knetwork manager used to show my ethernet connection and my unusable internal wifi card. It used to show my rt2500 card but not now and then now it shows nothing and says that it doesn’t work!

Your router is configured to provide ip addresses using DHCP and your interface gets an ip address by using dhclient. Once you have been assigned an ip address you need to check /etc/resolv.conf to confirm that the route was set properly. You should be able to access websites now. If not, then something else is wrong, perhaps networkmanager is overwriting the settings.

Thanks for your help everybody!

Sorry but i gave up with opensuse 11.0 with kde 4.1 and moved to xubuntu where my wifi worked in 5 mins. I liked it but it was a bit rough around the edges with it not being a proper release. I might come back for opensuse 11.1

One thing that did annoy me was how slow yast2 was to install things but i know that they are working to improve that.