RStudio Update Broken Dependency

Hello,

Did we actually deploy a version of RStudio dependent on one single version of this library? Which version is not available through the standard repo?

(base) powem@m4600-linux:~$ sudo zypper in rstudio
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides libboost_program_options.so.1.74.0()(64bit) needed by rstudio-1.3.1073-3.1.x86_64
 Solution 1: do not install rstudio-1.3.1073-3.1.x86_64
 Solution 2: break rstudio-1.3.1073-3.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c/d/?] (c):

Available library:


(base) powem@m4600-linux:~$ locate libboost_program_options
/usr/lib64/libboost_program_options.so
/usr/lib64/libboost_program_options.so.1.75.0
/usr/lib64/cmake/boost_program_options-1.75.0/libboost_program_options-variant-shared.cmake

I tried symlinking libboost_program_options.so.1.74.0 to libboost_program_options.so.1.75.0, but no joy.

By-the-by, option 2 does not work in the way expected. The installer runs but no executable is actually installed. However, as far as zypper is concerned, the package is installed.


Checking for file conflicts: ............................................................................................................[done]
(1/1) Installing: rstudio-1.3.1073-3.1.x86_64 ...........................................................................................[done]
(base) powem@m4600-linux:~$ which rstudio
which: no rstudio in (/home/powem/perl5/bin:/home/powem/.cask/bin:/home/powem/bin:/home/powem/.local/bin:/home/powem/anaconda3/bin:/home/powem/anaconda3/condabin:/home/powem/bin:/usr/local/bin:/usr/bin:/bin:/home/powem/.dotnet/tools:/snap/bin:/home/powem/bin/stockfish10:/usr/local/texlive/2020/bin/x86_64-linux)

Any help is much appreciated.

Thanks.

mp

You can install what you need from a private repo here
https://software.opensuse.org/package/libboost_program_options1_74_0

I wrote a Wiki article awhile back that describes how to find missing files, dependencies, packages, etc

https://en.opensuse.org/User:Tsu2/Missing_Files_Dependencies

TSU

Hi
Stop providing bad advice for a Tumbleweed user! The file is not missing, Tumbleweed has moved on and using boost version 1.75.

@powen, rstudio is not building at the moment (and it’s NOT a boost issue) Show openSUSE:Factory / rstudio - openSUSE Build Service

Until that is resolved and then rebuilds you will need to be patient. Hopefully won’t take long for a fix to be implemented, add your voice to the bug report 1180312 – [Build 20201222] rstudio uninstallable

The private repos are marked to be used on Tumbleweed.

TSU

Hi
Stop being obnoxious, RStudio is broken due to other reasons as explained in the bug report, it needs the unresolvable (as in not available) packages fixed and to rebuild.