RPM repository/database corruption


I manage a computer remotely in a different country. The last upgrade I did (to openSUSE 11.2) seems to have had one issue that I didn’t work out until later. I am unable to “Online Update” or “Software Manage” the system. Whenever I do I get the following error:

There was an error in the repository initialization.

'update': |] Valid metadata not found at specified URL(s)
- Can't hardlink/copy
/var/adm/mount/AP_0x00000001/repodata/repomd.xml to
- Can't provide /repodata/repomd.xml : Can't hardlink/copy
/var/adm/mount/AP_0x00000001/repodata/repomd.xml to

Each time the text f the error (the updateR0Fd2y part) changes.

I have been through a number of attempted fixes via the thread 434687-software-repository-corruption but have not managed to resolve the issue.

There is no one at the location that could repeat the “update” to hopefully fix the issue that way. I have a copy of the 11.2 DVD iso file on the remote computer. Is there some way that I can get the repository DB rebuilt or reinstalled so that I can then install other software and do Online Updates?

Whatever I try has to be doable with the system running so that I can OpenVPN connect and issue commands remotely.

rpm --rebuildindex

might work

worth a try

The problem seems to be with something cached in zyppers cache (go figure). So try this;

zypper clean

Thanks for the suggestion. I tried, but still the same error for “zypper -v refresh -f”.

Actually I have now solved the problem. I started manually downloading packages from Index of /update/11.2 starting with the zypp and yast2 related ones and installing (with any necessary dependencies.

Then I tried the “zypper -v refresh -f” again and got an entirely different error - “[Netrc.cc:103] Netrc:parse error. %s encounterd where ‘machine’…”. A search for this error turned up a Novell Bug report: https://bugzilla.novell.com/show_bug.cgi?id=567993

Which blamed the presence of a /root/.netrc file. I did have one for an old purpose. I removed this file and now everything is working perfectly.

Only took me 4.5 months to solve this one. But great, it is solved.