RPM Command giving an ERROR


rpm command was working fine for me till yesterday…
While I was installing gcc, I saw an error message saying rpmlib not found… So, when I tried to install all rpm components using Yast [Installation Source: dvd]… I was receiving some errors like ‘libselinux.so.1 cannot be installed: rpmlib not found etc’ I clicked ignore… Finally I completed the installation and closed the Yast… Now if I run rpm … I am getting an error like rpm: error while loading shared libraries: libse.linux.so.1: cannot open shared object file: No such file or directory. I dont even have yum installed on my system… If I try to open Yast Software Management, it doesnt do anything … Can anyone help me please…

I was just reading this zypper tutorial: Zypper/Usage/11.1 - openSUSE and there is an option to install a specific missing file in the repository. I wish I could advise you more but I don’t know how. Read this and try it. Good luck!

Thanks… Will try

Can you give us a rundown of what distribution version you have and what did you do exactly previously and where did you try to install this gcc?

I fix the issue by repairing the os using installation dvd