Rosegarden - First Note Only

I can play midi files from command line but not with Rosegarden. I’m using QSynth, with Pulseaudio because I can’t get Jack to start, and I get a bunch of messages “no preset found on channel X” where X is 0 to 15. Are those messages related to my problem, which is that Rosegarden plays only the first note of a midi?

OpenSUSE 13.1 (KDE 4.11.5) on laptop with integrated sound from AMD/ATI, two devices on-board (standard speaker/headphone and HDMI), plus a USB Tritton Soundbyte with better balance and more sound than the onboard. Veromix handles them well.

I’ve searched this forum and those of other distros, and based on the results, I’ve added myself to audio group, also pulse and rtkit groups, and I’ve added realtime priority and memory lock to limits config file. I’ve tried stopping pulse but even then jack won’t load (and pulse’s config file is supposed to load a compatibility module if it detects jack).

Any ideas how to get Rosegarden playing all the way through? If the idea is, to use jack, then any idea how to get it to start?*



*Output from attempt to start jack:

00:47:39.945 JACK was started with message buffer overruns
no message buffer overruns
no message buffer overruns
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2012 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in realtime mode with priority 10
control open "hw:0" (No such file or directory)
control open "hw:0" (No such file or directory)
creating alsa driver ... hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
control open "hw:0" (No such file or directory)
ALSA lib pcm_hw.c:1667:(_snd_pcm_hw_open) Invalid value for card
ALSA lib pcm_hw.c:1667:(_snd_pcm_hw_open) Invalid value for card
ALSA: Cannot open PCM device alsa_pcm for playback. Falling back to capture-only mode
Cannot initialize driver
JackServer::Open failed with -1
Failed to open server
00:47:40.185 JACK was stopped with exit status=255.
00:47:42.114 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel

jack server is not running or cannot be started


Out of “cat /proc/asound/cards” shows that my sound card is named generic. In qjackctrl settings, changing the interface from “default” or “hw:0” to “hw:Generic” allows the daemon to start.

However, once it’s started, I get no sound from Rosegarden.

Qsynth still shows pulseaudio as the driver in it’s settings, so maybe I should selectn jack? Okay, qsynth wants to restart, and when I OK that, it hangs.

Not sure if that qualifies as progress.


Look for
YAST > Hardware > Sound

If you don’t see it, install it

zypper in yast2-sound

You should then be able to do some ALSA and Pulse configuration.
Several years ago, in an earlier openSUSE (11.3?) I had to manually set the sound device as “hp device”
It wasn’t a dropdown option, but I found the setting in some documentation and entered it manually.

You may require something similar.


Thanks, TSU. I certainly have the sound module installed, and I can use it to turn pulseaudio on or off without respawn. I also have a lot of options on the card which can’t be cut’n’pasted; would it help to post 'em here? So far my internet search hasn’t turned up any suggestions to change 'em.

To recap,

I have qsynth setup (with fluidsynth and soundfonts) which can play a midi file beautifully on its own, using pulseaudio. Rosegarden can play to qsynth - I see the indicator flashing on qsynth control panel - but hear only the first note.

I can start jack, with or without pulseaudio. Technically this is jack2, which is supposed to work with pulse, and the config file loads the jack module*. With or without pulse enabled, the behavior is the same: No apps will play through the sound card which jack controls (though I can attach a usb sound device that still works, assuming I don’t tell jack to control it too). Qsynth can start with jack as the sound driver, but then instead of hearing the first note from Rosegarden, I hear nothing at all. Indicator on qsynth still flashes to indicate that it is receiving input. Behavior does not change when I have jack started in real-time mode or not. Of course, I don’t have a real-time kernel; from what I’ve read, that shouldn’t be necessary anymore. If it is, I’ll abandon the project.

Writing music, and having my computer play it, sounds neat. In high school band, back in the day, I had a poor sense of timing along with poor pitch discrimination; in short, I sucked, even though I aced all the theory tests. Rosegarden can address my weaknesses there, but it’s just something fun to try, not related to how I earn a living, so any “invasive procedure” that could brick my installation isn’t worth the risk.

Are any openSUSE fans using Rosegarden, or do all the musicians live in some other distro optimized for the purpose?


*from config file

### Automatically connect sink and source if JACK server is present.ifexists
load-module module-jackdbus-detect channels=2

Well, mark this’n solved, sorta…weekend’s over so I’ll fall back and punt: Uninstalled Rosegarden and Jack, installed MuseScore.


Are any openSUSE fans using Rosegarden, or do all the musicians live in
some other distro optimized for the purpose?

Yes, Rosegarden is in fact the sequencer I use the most, and I believe openSUSE is as
capable as any other distro for the audio production purpose. Some distros will, however,
have automatically set up some of the needed configurations for an audio production
environment, which users of a non-dedicated audio distro, as openSUSE, will have to
manually go through themselves.

I saw there were some improvements as you eventually managed to start JACK (post
1 > post 4), did you do anything to your system between those posts?

In the initial case (JACK log) there seemed to be some problems with JACK and the
audio-device; my guess is that this is PA related. Generally, though, if you have not
set up the limits.conf file, which grants priorities for audio users, JACK is likely to
refuse to start.

In the out-put you presented, JACK was started with the priority value 10, which
is considered too low; 70 is, IME, often a recommended value here. I would recommend to use
QJackCtl to change that value; QJackCtl provides a good interface for further tuning your system
so you may utilise it for this purpose as well; it may also be preferable to start JACK from here: easy to
manage connections, good monitoring tool etc.

Even though Rosegarden will auto-start JACK you may, if you have several
audio-devices/cards, use ALSA/OSS clients as source as well; I do that from time to
time with ZynAddSubFX (OSS), and it works fine.

PulseAudio and JACK has had a problematic relationship, though there seem to be ways around (most of) those
problems now a days; if you don’t need PA, however, and audio production is important to you, I would
recommend to disable/remove it.

I appologise, did not read through carfully; treat my post as a general view on the matter (saw you used QJackCtl and had the limits.conf set up).

In any case, if you wish to use your intial set-up with JACK + Rosegarden and QSynth, you should be fine; PA is probaly the cause of the problems.
I have two computers running OS 13.1 which both are quite capable as (home) DAWs.

A bit old but still mostly relevant.
If you wish to follow it, just ask along the way: for instance, the multimedia repoes are not needed on 13.1.

Thanks for the input, F Sauce. I found the drop-boxed doc helpful but still have no sound from jack, even with priority 70 and latency 5.3ms. In my previous internet searching, I hadn’t found any reference to the settings that bring down latency or what the target should be. The defaults on my installation yielded 64ms.

When I configure QSynth to use jack as both midi driver and audio driver, then in Rosegarden I don’t see a channel to assign the output to. However, when I set jack as the midi driver but keep pulse as the audio driver, I see a midi output channel in Rosegarden (130, QSynth1) and as per title of this thread, I hear the first note of any midi file I play.

With jack active, any other audio app (like chrome on a youtube page) won’t play through the sound device that jack controls.

All this is true whether or not I disable pulse (through yast), though I haven’t tried uninstalling it completely. So I’ve got a Sunday afternoon and a Friday night with no music, nothing to show but a reminder of how far linux has come since the days when every program was this frustrating.



After you disable PA, do you re-login or reboot? That is important.
Whether you deinstall or disable PA should not matter, though.

Make use of QJackCtl, and tell what the connection table of both ‘ALSA’ and ‘MIDI’ displays, and you could include the the ‘Audio’ tab as well.
Also, check the device set-up of JACK in QJackCtl.

With jack active, any other audio app (like chrome on a youtube page) won’t play through the sound device that jack controls.

While JACK is running, it will prevent any sound instance from ‘outside’ JACK using the card; this is also the case with PA, hence the problems.
Initiating JACK from Rosegarden, i.e. starting Rosegarden before JACK is running, may keep the system still running ‘jackd’ after you have terminated the audio-session; check whether the jack daemon is running: ‘top (terminal)’ or ‘Ctr + Esc’ in KDE.

I hadn’t found any reference to the settings that bring down latency or what the target should be. The defaults on my installation yielded 64ms.

If you use the ‘desktop’ kernel you should be fine, check this with:

uname -a

If you have doubts about altering your system to much without appropriate knowledge, you may consult these sources:

Strange with the one note output, though, but I think you should be fine eventually; I have had a similar set-up as your initial attempt for years without much trouble, can’t see why you shouldn’t also.
Audio-devices, as well as other hardware capabilities, may be a factor in regards what good a performance you may potentially get, but whether you have a 5ms, 10ms or 20ms etc. latency configuration set-up should not give you the problems you currently have.

Try disable PA, reboot and then set up JACK from QJackCtl; start JACK from QJackCtl, start QSynth and then start Rosegarden.
Post back to report how it went.

Good luck!


BTW, this is a good wiki, ‘System configuration’ might be most relevant to start with:

Thanks again, Olav, and sorry it’s been so long since I could get back to Rosegarden. Let me confirm I have desktop kernel. I did these steps in order you listed, which I think I’d actually tried before, and I get the same symptom: First note (or chord) only.

QJackCtl connections window shows:

Audio tab
qsynth → system
rosegarden → system
system → rosegarden

ALSA tab
131:rosegarden → 130:FLUID Synth (3033)

Any clue there?


Sorry, I missed out on this, have been away.
How is it going?