ROOT>var>run>media>%user% is out of space

openSUSE 12.3
KDE 4.10

I have been testing some backup procedures and they all blow up when they get to the Virtual Box, Windows XP directory, the .vdi file.
The file is 5.0Gb and I need to make something bigger so I can make a copy of that one file.
Apparently all files go through >media to get to their ultimate destination so, how can I expand whatever it is that I need to expand.


I already wrote that yesterday.
/var/run/media/$USER/xxxx is your external hard disk.
Just make sure it is mounted when you run the backup. And check that it has enough empty space for the backup.

Glory be, but I think that you are mistaken, and I hope you are not.
I am thinking that var>run>media is either used temporarily or checked for space before the copying begins.
On my PC it has 1.2 Gb of space, the external HDD has 90Gb free.

I even tried a simple copy within Dolphin of the 5gb file and it only gets so far when it stops.
I will try it from the command line tomorrow to see what’s up.

Why do you think that?
Mount your drive with KDE (i.e. click on it in dolphin) and have a look at the output of the command “mount”.

If it is not mounted, you are writing to the tmpfs /var/run/ instead which has only a size of 1GB (it is kept in RAM).

What are yo using to backup?

Not sure what 1.2 gigs is. Is that free space on root or used or what?? If free space on root you may have too many tmp files clear them out.

Some backup methods do use tmp space particularly if you use compression

rsync is good if the target file system is Linux based but Windows based file systems lose permission bits since the file systems don’t support them

If you are backing to Windows format media best to use a container like gz or tar etc since they save the permission bits. but they do use lots of tmp space to build.

The 1.2 is free space on either var, run, or maybe media. As I was stepping through the tree with Dolphin, that is the number I saw.

I used Grsync initially, then after I reviewed the error report and saw that the 5gb got skipped, I tried it again in Dolphin. Another error.
question. When I tried Dolphin, I had a split screen, 5gb on the left, USB HDD on the right, click and drag, and that did not work. I don’t remember the error message but I am pretty sure it was about not enuf space.
Would Dolphin let me do that if USB HDD were not mounted ?

The USB HDD is a Fat 32 format but I can make it whatever I want.
What do you suggest ?
The losing permissions is startling.

Sent from my iPad

If I were more familiar with Linux commands I think I could make my case from Konsole.

some command to show the status and capacity of USB-HDD

another command to copy the 5gb to USB-HDD (cp ?)

I’ll figure them out tomorrow.

fdisk -l will give info about partitions and partition size

Also df gives size info.

If you have a normal setup /var/run and /run are temp file systems thus work out of memory df will show what is what

mount shows what is mounted from where
df will show space available and where mounted and file system

/etc/fstab file controls what gets mounted where at boot

Install luckybackup, connect the external HDD and create a profile where all desired files and folders will be copied to the external HDD. You can reuse that every time. Or create a rule where this HDD gets mounted on /backupdisk or something alike.

That’s what I had done Knurpht and I kept getting a lot of red error messages so I tried to simplify things. I might go back to it when I get this sorted out.

FAT32 only takes files of up to 4GB. Try a different file system.

I tried running again from Kconsole and got this: As you can see, there is plenty of room on USB-HDD (green lines), yet it failed due to lack of space (red lines).
I do not know what the error code 22 are, and they are on insignificant files so not so improtant other than it might happen on crucial files, so it needs research.
Also, some of the switches in rsync cause me trouble. I need to read more so as to have files that retain their original status as to ownership, priviliges, etc.
Kinda weird that that is not the default.

Another commenter said that a Windows file type would lose some features, and then I just read that FAT 32 has a 4gb file size limit.
Thanks chief !!!

TADA, there is the problem.

Ok, solved, now what format should I use ?

linux-qq35:/home # df
Filesystem     1K-blocks     Used Available Use% Mounted on
devtmpfs         1882136        8   1882128   1% /dev
tmpfs            1898412     4080   1894332   1% /dev/shm
tmpfs            1898412     3776   1894636   1% /run
/dev/sda6       20641788  8422600  11170616  43% /
tmpfs            1898412        0   1898412   0% /sys/fs/cgroup
tmpfs            1898412     3776   1894636   1% /var/lock
tmpfs            1898412     3776   1894636   1% /var/run
/dev/sda7      311830312 21702032 289177880   7% /home
**/dev/sdd1      117162560 13469216 103693344  12% /run/media/hexdump/6CC2-7168
/dev/sdd1      117162560 13469216 103693344  12% /var/run/media/hexdump/6CC2-7168**
/dev/sdc1       15617104    40680  15576424   1% /run/media/hexdump/openSUSE 12.3 KDE Live
/dev/sdc1       15617104    40680  15576424   1% /var/run/media/hexdump/openSUSE 12.3 KDE Live
linux-qq35:/home # rsync -v -r hexdump /var/run/media/hexdump/6CC2-7168/h1 >1.txt
rsync: mkstemp "/var/run/media/hexdump/6CC2-7168/h1/hexdump/..xsession-errors-:1.HQTFPc" failed: Invalid argument (22)
rsync: mkstemp "/var/run/media/hexdump/6CC2-7168/h1/hexdump/.kde4/share/apps/amarok/albumcovers/cache/.28@script_NULL_Download failed :(_cover.png.cxSHUU" failed: Invalid argument (22)
rsync: mkstemp "/var/run/media/hexdump/6CC2-7168/h1/hexdump/.kde4/share/apps/amarok/albumcovers/cache/.28@script_pursuit _Bangs, John Kendrick. "Pursuit of the House-Boat, The"_cover.png.q4wYqX" failed: Invalid argument (22)
rsync: mkstemp "/var/run/media/hexdump/6CC2-7168/h1/hexdump/.kde4/share/apps/amarok/albumcovers/cache/.28@script_pursuit _Tozer, Aiden Wilson. "Pursuit of God, The"_cover.png.AFBDYZ" failed: Invalid argument (22)
rsync: mkstemp "/var/run/media/hexdump/6CC2-7168/h1/hexdump/.local/share/local-mail/trash/new/,S.zIZB9g" failed: Invalid argument (22)
rsync: writefd_unbuffered failed to write 4 bytes to socket [sender]: Broken pipe (32)
**rsync: write failed on "/var/run/media/hexdump/6CC2-7168/h1/hexdump/VirtualBox VMs/Windows XP/Windows XP.vdi": File too large (27)
rsync error: error in file IO (code 11) at receiver.c(326) [receiver=3.0.9]**
rsync: connection unexpectedly closed (180990 bytes received so far) [sender]
rsync error: error in rsync protocol data stream (code 12) at io.c(605) [sender=3.0.9]
linux-qq35:/home # 

As suggested, I am going to try LuckyBackup again. I expect better things this time.

On 2013-08-29 17:57, hextejas wrote:
> Ok, solved, now what format should I use ?

For rsync type backups, use the same or equivalent format as the source.

Meaning, for a backup of Linux, use a Linux filesystem (fi, EXT4). For
backup of Windows, use a Windows filesystem (fi, NTFS).

If you are adventurous, you could use btrfs with compression
(experimental feature).

Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)