root partition failed (cannot boot now)

All of a sudden, my tumbleweed + KDE system stops responding. It happened several times before and came back to normal after hard reboot. But this time it is different. I need some advices on how to recover it.

I have not upgraded this system for about ten days but it works well until just now. I suspended it to RAM yesterday night before going to sleep and did not use it for a day. I resumed it about one hour ago and it worked as normal. After a while, the system stopped responding while I was copying a file to USB stick. I hard rebooted it and it successfully entered the desktop. When I tried to check system log for the problem, it halted again for about one minute and rebooted itself. But this time it cannot successfully boot into desktop. I find out that the root partition was reported as read only. It is a btrfs partition on a nvme ssd.

I tried to reboot the laptop by hard pressing on the power button and it booted into emergency mode saying btrfs error on device nvme0n1p6 (my root) and cannot mount /sysroot .

Please advice on how to recover it. Should I reinstall it instead of rescue?

Sorry for the error in the post and no further details. I found it is very challenging to post on mobile phone. I will check back after about 23 hours because of being fully occupied tomorrow.


What you have described are symptoms of hardware failure. Does a live media or external HD boot behave any better? From a live Linux media boot you should try running smartctl. This includes selecting “Rescue System” from TW installation media. Have you looked on the support site of your nvme device maker for instructions how to test the condition of the device?

Thank you for your reply. Sorry that I could not provide more detail at the moment. I had not prepared a rescue media. Maybe I’ll try to rescue it before I reinstall after making an installation media.

Does anybody know a way to rescue from emergency mode?

First thing to try when booting from a Live/Rescue medium, is to try mounting the btrfs partition.

I can only confirm the ssd is not dead at the moment but the status of the root partition is unknown.

Thank you, Knurpht. I tried to mount the partition from rescue console. It said “can’t read superblock on /dev/nvme0n1p6” but other partitions were mounted successfully. Any ideas?

As of this morning’s update I cannot boot into my Tumbleweed install. I get numerous failures in systemd and the root partition (which is XFS) is mounted as read-only. This happened immediately after an update and reboot and the SSD is brand new so I don’t believe there is a hardware failure going on. My situtation sounds fairly similar to what else has been reported here.

After booting with rescue media, I ran some checks and found this problem looked very similar to this one “

But the quoted problem is not solved. So I just re-installed the system. The installer cannot recognise the aforementioned partition either so I just formatted this specific partition. After installation, the system works as expected.

Sorry to hear that but we might have different problems.

For general info since you reinstalled as a solution. The error indicates file system corruption. Sometimes running fsck can fix these things some times not depend on how bad the corruption is ad the FS in question…

Have a look at the entries in /etc/fstab.

If there are 2 references to swap files delete the one that is not on the same disk as the root directory.

I forgot to mention but I did try to use btrfsck to check the partition. I do not remember the error message but the btrfsck has no use on this issue. Actually, I think the referred post in has gone further beyond btrfsck and I have tried the ways mentioned in that post. No avail.

Thank you but the failed partition is root partition (mounted on / ). I did not use swap files but swap partition on that system.

Thank you all for the heads up. Following urls is the photos I took on the failed checks:

I cannot wait to solve the problem so I have reinstalled the system. The SSD is good so the partition works well after formatted.

Hmmm you said root was XFS not BTRFS so btrfsck would not work anyway,. best to just run fsck and follow instructions from there.

get numerous failures in systemd and the root partition (which is XFS)

Well in any case you are running again

Apologies for my diction,

  • the fstab file only refers to partitions
  • swap is on its own partition
  • the swap in use may be better if it is on the same drive as the root partition

random thoughts

  • is the ssd SATA I,II or III
  • is the main/motherboard SATA I,II or III
  • if SATA of ssd and main/motherboard are not the same are they both up/downwards compatible
  • if SATA III is involve, is the data connect cable less than or equal to 30 cm.


  • if the data connection to the booting disk is being corrupted the bios may stick or take minutes to load and monitor will only show a blinking cursor

I fixed my issue. You were right that it wasn’t related to yours. For whatever reason, my root partition line went bye bye from my fstab file. I added it back in and all is good again.

I had the same problem. After re-formatting, the drive now works again for months, so it does not look like a HW problem. After some research here, I thought that it might be related to BTRFS snapshots on drives with little capacity left. But as I needed the disk, I could not research further, reformatted it and disabled snapshots. No problems since then.