Root Logons Not Allowed

whent to switch to root in KDE, and at the login attempt I got the above message.
Any clue on to why?. I can logon to root from the shell, but not KDE.

Will be poking around a bot more tonight and keeping an eye on here.

thanks…

Logging on graphically is NOT recommended thats why it is disabled by default. It can be dangerous. However you can enable it by following this guide:

HOWTO to enable local root login

However I highly recommend not doing this and I will never do it myself. You have be warned. Why do you need to log on as root through KDE anyway?

i need to alter some settings in kde, and dont want the plasmoids running while i do this. a plasmoid isnt updating as it should and i want to rename the config setting file and then restart it. when did not permitting logon as root in a gui become the fashion in opensuse??? :frowning:

Read this first: SDB:Login as root - openSUSE.

I do not quite understand what you want to change in KDE, but when they are settings for an end-user then root should not be involved at all. When you, as end-user, want to do something while not loged in into the GUI (and thus not using KDE), login as that end-user in he CLI: Use Ctrl-Alt-F1 to go to the console where you will see a login prompt. Use your end-users username and password (while typing the password, you will see nothing echhoed) and there you are.

After your action, logout with the exit command, so Ctrl-Alt-F7 and thus go back to your graphical login screen.

No need to start KDE as root to change user config files. If you want this to change appearance of Yast for example, do


kdesu systemsettings

This will give access to root’s systemsettings, i.e. you can change the appearance of programs running with root permissions.

On Tue, 19 Oct 2010 07:06:02 +0530, AdmiralFubar <AdmiralFubar@no-mx.forums.opensuse.org> wrote:

> i need to alter some settings in kde, and dont want the plasmoids
> running while i do this.

if you want to edit some plasmoid’s config files while it’s not running, just type
“kdequitapp plasma-desktop” in a (user-) terminal, then edit the plasmoid files, with kate, kwrite, or whatever. when you’re finished, type
“plasma-desktop & disown” in the same terminal to start the desktop again. that terminal will also keep providing output from plasma-desktop which may tell you something about errors in your plasmoid. because of “disown” in the command, you can close that terminal again w/o closing plasma-desktop.

> a plasmoid isnt updating as it should and i
> want to rename the config setting file and then restart it. when did not
> permitting logon as root in a gui become the fashion in opensuse???

i wasn’t aware that it ever was in fashion. while i value the idea of being able to log in graphically as root, i never felt the need to actually do so.


phani.

On 2010-10-19 03:36, AdmiralFubar wrote:
>
> i need to alter some settings in kde, and dont want the plasmoids
> running while i do this. a plasmoid isnt updating as it should and i
> want to rename the config setting file and then restart it. when did not
> permitting logon as root in a gui become the fashion in opensuse??? :frowning:

Notice that if you go about changing a user config or renaming his files, as root, those changes may
well end by making that user account “broken”, no permission.

Which is one of the reasons for disabling root login.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

AdmiralFubar wrote:
> when did not permitting logon as root in a gui become the fashion
> in opensuse??? :frowning:

since forever…

it has never been advisable…

and never been needed for any admin duty whatsoever…

http://en.opensuse.org/SDB:Login_as_root


DenverD
When it comes to chocolate, resistance is futile.
CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]