Rocketfish Webcam not working on Tumbleweed. Plasma desktop.

OK this is weird. This camera works when I plug it in the front USB connector.
Going to one on the backplane Cheese and the “Webcam Application” both give error messages.
I’ve tried different physical USB connectors on the backplane. Same errors.
The setting are set to auto in the “Webcam Application.”
Cheese doesn’t give you any configuration.
Cheese and Hangouts both worked in the past so I know the Webcam worked at one time when plugged into the backplane.
Camera shows up on YAST Hardware settings but looking at the exported hardware file it’s seen as a sound device. I’d like to get this working again.

  P: /devices/pci0000:00/0000:00:14.0/usb1/1-3/1-3:1.2/sound/card0/controlC0
  N: snd/controlC0
  S: snd/by-id/usb-Rocketfish_Rocketfish_HD_Webcam_2010052803943-02
  S: snd/by-path/pci-0000:00:14.0-usb-0:3:1.2
  E: DEVLINKS=/dev/snd/by-path/pci-0000:00:14.0-usb-0:3:1.2 /dev/snd/by-id/usb-Rocketfish_Rocketfish_HD_Webcam_2010052803943-02
  E: DEVNAME=/dev/snd/controlC0
  E: DEVPATH=/devices/pci0000:00/0000:00:14.0/usb1/1-3/1-3:1.2/sound/card0/controlC0
  E: ID_BUS=usb
  E: ID_MODEL=Rocketfish_HD_Webcam
  E: ID_MODEL_ENC=Rocketfish\x20HD\x20Webcam
  E: ID_MODEL_ID=0218
  E: ID_PATH=pci-0000:00:14.0-usb-0:3:1.2
  E: ID_PATH_TAG=pci-0000_00_14_0-usb-0_3_1_2
  E: ID_SERIAL=Rocketfish_Rocketfish_HD_Webcam_2010052803943
  E: ID_SERIAL_SHORT=2010052803943
  E: ID_TYPE=audio
  E: ID_USB_DRIVER=snd-usb-audio
  E: ID_USB_INTERFACES=:0e0100:0e0200:010100:010200:
  E: ID_VENDOR=Rocketfish
  E: ID_VENDOR_ENC=Rocketfish
  E: ID_VENDOR_ID=19ff
  E: MAJOR=116
  E: MINOR=9
  E: SUBSYSTEM=sound
  E: TAGS=:uaccess:
  E: USEC_INITIALIZED=1241649255
  P: /devices/pci0000:00/0000:00:14.0/usb1/1-3/1-3:1.3
  E: DEVPATH=/devices/pci0000:00/0000:00:14.0/usb1/1-3/1-3:1.3
  E: DEVTYPE=usb_interface
  E: DRIVER=snd-usb-audio
  E: ID_USB_CLASS_FROM_DATABASE=Miscellaneous Device
  E: ID_USB_PROTOCOL_FROM_DATABASE=Interface Association
  E: INTERFACE=1/2/0
  E: MODALIAS=usb:v19FFp0218d0008dcEFdsc02dp01ic01isc02ip00in03
  E: PRODUCT=19ff/218/8
  E: TYPE=239/2/1
  E: USEC_INITIALIZED=1241644528

USB3? 2? 1? Both the port and the device

Camera is USB 2
Port is USB 3

Bet the front port is USB2

Some USB 3 chips seem to not like Linux

Maybe take a look at lsusb and see what is there someone may have experience with that hardware

That is now my guess too.
What is strange is have a powered USB 2.0 hub with a bunch of USB 2.0 hard drive enclosures plugged into the same USB 3.0 backplane and I can access sess all those drives when I turn that all on.
I ordered a low profile USB 2.0 card. I hope that will solve the problem.

Thanks for the trouble shooting help.