Rewrite command not found

I am trying to install mecab (MeCab: Yet Another Part-of-Speech and Morphological Analyzer)

which requires mecab-ipadic. In the makefile I have following line

matrix.bin char.bin sys.dic unk.dic:
$(mecab_dict_index) -d . -o . -f EUC-JP -t euc-jp
echo To enable dictionary, rewrite /usr/local/etc/mecabrc as “dicrc = /usr/local/lib64/mecab/dic/ipadic”

After everything compiles fine I try to enable the dictionary but my OpenSuse 12.3 64 does not have a rewrite command

Yast2 also did not find anything. Where can I find it ?

Thanks . Db.

There is no rewrite command.

I think that message means, you should edit the file “/usr/local/etc/mecabrc” with a text editor so that it contains “dicrc = /usr/local/lib64/mecab/dic/ipadic”…:wink:

On 2013-07-13 17:26, Darkblue2 wrote:

> matrix.bin char.bin sys.dic unk.dic:
> $(mecab_dict_index) -d . -o . -f EUC-JP -t euc-jp
> echo To enable dictionary, rewrite /usr/local/etc/mecabrc as “dicrc =
> /usr/local/lib64/mecab/dic/ipadic”
>
> After everything compiles fine I try to enable the dictionary but my
> OpenSuse 12.3 64 does not have a rewrite command

It is not a command. It is human language instructions for you do the
rewrite :slight_smile:


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

Thank you both , I got it to work by putting the line into the relevant configuration file.

Db