Reverting some Firefox 106 Changes...

Firefox 106 has introduced a few changes (aka “improvements”), which Luddites like myself might wish to revert:

Private Browsing now uses a Dark Theme by default:

Set “browser.theme.dark-private-windows” = false to disable

Optionally to remove the new logo and indicator

Set “browser.privatebrowsing.enable-new-logo” and “browser.privatebrowsing.enable-new-indicator” = false

To disable the new Firefox View feature:

Set “browser.tabs.firefox-view” = false

I also noticed in 15.4 FF 102.3.0 that scrollbars where acting strange. They became very small and then widened (still very small, that was another frustrating one longer ago, where the scrollbar width did not follow anymore what I defined in KDE) when hovering. Very disturbing.

Found in the Settings menu/page (not the about:config) down to Navigate: Scrollbars always visible. That worked.

I do not really mind when people want to add new features to a product, but why oh why are they so convinced of their own “improvements” that they want to force it upon innocent users by switching it on? Users then run mad and can go and search endless where to switch the nonsense off?

You can also set the overall width of the scrollbars by using (about:config)

“widget.non-native-theme.scrollbar.size.override” and setting to a value of your liking. (14 would be a reasonable starting point and adjust ± from there).

There is
widget.non-native-theme.scrollbar.size 16 also, no idea why that is not used, but yoursuggestion:
widget.non-native-theme.scrollbar.size.override 16 makes it much better for me. Thanks a lot!

Come back to this after a few minutes of working with FF. A real improvement! Don’t have to hit predicsely that small dark line anymore. I now get to the scroll without much thinking, more automatic and better workflow.

In short: :good: and you made my day <:)

Glad you found it useful :slight_smile:

Yes I too found the default size rather narrow for my liking, I’m not into this pixel precision mouse pointing, getting far too long in the tooth for it…

Same setting applies to Thunderbird if you use that…

Great!

On my 15" 4K Laptop display this is a really helpful. Thank you very much for sharing this!

Now I still have to find out how to archive the same in libreoffice.

Regards

susejunky

I don’t use Thunderbird, but as I see that more have difficulties with small scrollbars, these are the notes I made in 2019 when adapting KDE scrollbars in general:

See: https://forums.opensuse.org/showthread.php/533904-KDE-themes-and-widgits-and-whatnots-Scroll-bar-width-in-Firefox-and-LibreOffice/page3]
(and visiting I saw that @tannington is there also the hero of the thread :wink: )

I added this to .config/gtk-3.0/gtk.css:

scrollbar, scrollbar button, scrollbar slider {
  -GtkScrollbar-has-backward-stepper: 1;
  -GtkScrollbar-has-forward-stepper: 1;
  min-width: 10px;
  min-height: 10px;
}

There was also

  -GtkScrollbar-has-secondary-backward-stepper: 1;

for a second arrow-up, which I left out.

That now only works for some gtk applications, FF and TB no longer use it as the about:config settings now supersede it.

On my system

Operating System: openSUSE Tumbleweed 20221015
KDE Plasma Version: 5.26.0
KDE Frameworks Version: 5.99.0
Qt Version: 5.15.6
Kernel Version: 6.0.1-1-default (64-bit)

> inxi -Gxx
Graphics:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
    vendor: Micro-Star MSI driver: i915 v: kernel arch: Gen-5.75 ports:
    active: DP-1 empty: HDMI-A-1, HDMI-A-2, HDMI-A-3, VGA-1 bus-ID: 00:02.0
    chip-ID: 8086:0412
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: kwin_x11 driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 96
  Monitor-1: DP-1 model: AOC U2790B res: 3840x2160 dpi: 163
    diag: 685mm (27")
  OpenGL: renderer: Mesa Intel HD Graphics 4600 (HSW GT2) v: 4.6 Mesa
    22.2.1 direct render: Yes
>

LibreOffice 7.4.1.2

… this does not change the libreoffice scrollbar size at all :frowning: Even if I use 50px there is no change visible.

Regards

susejunky

As I tried to explain, this is a general KDE setting. And at least some KDE applications (like the PIM ones as Kmail) follow it. Firefox did it for some time (until some time ago). I do not know about the others and I doubt very much about LibreOffice (and you confirm it doesn’t).

It is a step by step process :disapointed:

Libreoffice is more of a challenge…

As you’re using KDE you will (likely) have the KDE integration package “libreoffice-qt5” if you are prepared to sacrifice that and install “libreoffice-gtk” then the changes made to “.config/gtk-3.0/gtk.css” will take effect.

Alternatively, consider using a different widget theme in KDE, I’m using QtCurve which with LO + libreoffice-qt5 gives me this:
https://paste.opensuse.org/view/raw/a9816f05

Although both those “solutions” result in a significant change to the overall look and feel…

Indeed “libreoffice-qt5” was installed so i removed it.

The change in “look and feel” does not bother me BUT the scrollbar size will not change whatever value I put in “~/.config/gtk-3.0/gtk.css”.

I will try this next …

My 27" 4K desktop Monitor is not that much of a problem but using libreoffice on my 15" 4K Laptop display is a real pain.

Many thanks to you and hcvv for helping!

Regards

susejunky

I’ll ask anyway, but I feel sure you did… and installed “libreoffice-gtk” in it’s place?

Haven’t looked at this for quite some time, so it may have changed in the interim period… I’ll go try…

Works here OK when libreoffice-gtk3 is installed:

...
   min-width: 14px;
   min-height: 14px;
...

https://paste.opensuse.org/view/raw/f9c83ed1

...
   min-width: 28px;
   min-height: 28px;
...

https://paste.opensuse.org/view/raw/79057cce

SORRY, my fault !!!

After installing “libreoffice-gtk” the libreoffice scrollbars can be controlled by the settings in “~/.config/gtk-3.0/gtk.css”.

Great!

Thank you very much indeed !!!

Regards

susejunky

No problem :slight_smile:

Of course replacing libreoffice-qt5 with libreoffice-gtk will mean that you get the Gnome File Picker rather than KDE’s, so you may have to weigh that against the ability to change the size of the scrollbars.

Isn’t there always a price that has to be paid ?:wink:

I do not fancy the GNOME file picker but it does not disturb me either whereas the narrow scrollbars made working with libreoffice a real pain especially on the “small” laptop display.

But now everything is fine!

Regards

susejunky