Revert to previous version of Thunderbird ?


Any idea how I can revert to the previous working version of Thunderbird ? Unfortunately the various download mirrors don’t seem to keep older packages. The current TB is seriously buggy and downright unusable.


You are posting it in openSUSE forums and tagged question with Leap 15.1. All updated versions released for 15.1 starting with GA are available; you can revert to any previous released version and lock it.

More specific answer needs more specific question.

For Leap 15.1, they should be there.

Click on the “Versions” tab in Yast software management.

OK, so I finally managed to get a sane Thunderbird back. I stand corrected, because the OpenSUSE updates mirrors do keep subsequent RPM versions, so I simply downloaded the next to last in line and installed it using rpm -ivh .

The update also wrecked my configuration in ~/.thunderbird. Fortunately I have a local Rsnapshot server running, so I fetched yesterday’s ~/.thunderbird, and everything was fine.

Since I have absolutely no time to deal with this, I locked the app for the time being.


Using YaST, the following Thunderbird versions are listed: 68.1.1; 60.8.0; 60.7.2; 60.7.0; 60.6.1.

  • “zypper search --details --match-exact MozillaThunderbird” delivers the same information.

IMHO needs less time an effort than searching the update mirrors

The latest 60.x.x version is 60.9.0, and the latest 68.x.x is 68.1.2

Correct but, not for the openSUSE distribution – it normally takes a little bit of time before the source code passes through the openSUSE Build Service and, the associated openQA process <>:

 > zypper search --details --match-exact MozillaThunderbird
Loading repository data...
Reading installed packages...

S | Name               | Type       | Version             | Arch   | Repository                     
  | MozillaThunderbird | package    | 68.1.1-lp151.2.13.1 | x86_64 | Hauptaktualisierungs-Repository
  | MozillaThunderbird | package    | 60.8.0-lp151.2.10.1 | x86_64 | Hauptaktualisierungs-Repository
  | MozillaThunderbird | package    | 60.7.2-lp151.2.7.1  | x86_64 | Hauptaktualisierungs-Repository
  | MozillaThunderbird | package    | 60.7.0-lp151.2.4.1  | x86_64 | Hauptaktualisierungs-Repository
  | MozillaThunderbird | package    | 60.6.1-lp151.1.9    | x86_64 | Haupt-Repository               
  | MozillaThunderbird | srcpackage | 68.1.1-lp151.2.13.1 | noarch | Hauptaktualisierungs-Repository
  | MozillaThunderbird | srcpackage | 60.8.0-lp151.2.10.1 | noarch | Hauptaktualisierungs-Repository
  | MozillaThunderbird | srcpackage | 60.7.2-lp151.2.7.1  | noarch | Hauptaktualisierungs-Repository
  | MozillaThunderbird | srcpackage | 60.7.0-lp151.2.4.1  | noarch | Hauptaktualisierungs-Repository

The current openQA success rate is here: <>.

Hello, I am new to this forum, I am reporting this because I believe it can be usefrul.
I just installed opensuse 15.2 on a new laptop, thunderbird has been problematic at least during the last year, I had to revert to version 60 in order to be able to see my mail directory structure. Thunderbird version 68 starts with a blanck page and I cannot see my mails and folder structure any longer. The addresses are fine, I can see all of them, but the rest, filters and messages are all somehow invisible, gone and I didn’t find a way to have thunderbird to show them again. Using version 15.1 of opensuse I was able to revert to version 60 using yast, this time I have found an rpm on the net to do so. I do not have the time to fiddle with it so much, I have tried different things and with different mail programs, and I have not been able to get back my messages in any way, not even importing using a different mail program. So I downgraded thunderbird to version 60 again and for now I will stay there, now everything is working fine again. I am going to block the update to the program. If somebody could tell me if a maill program can import fully thunderbird repositories I will really appreciate it, I have tried several but none works. Regards.


First, welcome to the openSUSE forums.

That said, please understand that this is a thread with a specific question about Thunderbird in openSUSE LEAP 15.1.

You have a different question, were in only because you run 15.2.

When you want to draw the attention to your problem, please start a n ew thread with the correct prefix to the title and a title that show keywords related to your problem. Do not attach a different questions about another version at the end of a thread, we want to avoid confusing discussions and your problem will probably not be seen as a new one that needs new help.

This thread will be closed.