revert problems on clean install of openSUSE 11.3

I ran into the nvidia problem when I moved from kde 4.5.95 to kde 4.6.0, floating point exception.

After much hair tearing I reverted to a clean install of 11.3, kde 4.4.4.

I’m now having problems with kmail and akonadi (with repeated install strategies failing)

akonadi is showing install errors,

kmail is downloading email happily from my ISP but any attempt to compose, edit or send, freezes kmail/kontact.

I’ve assumed I’ve got default setting compatibility problems somewhere in .kde4 (after all it’s a clean install but as we know /home is unaffected)

Despite a slash and burn policy to anything that isn’t my stored emails I’m not really getting anywhere.

Apart from the kmail problem the clean install is sweet.

An alternative strategy might be fall back to legacy nvidia as (reportedly) they do not interact with kde 4.6

May I ask for help/advice please?

Hello gerrygavigan,

If I’m right your problem is that after a clean install of 11.3 (without formatting your /home) you have problems with kmail and some other applications.

I suggest you create a new user and copy over user data, no settings from your old user.
And then reconfigure the troublesome programs.

Although copying the config files should/could work it’s better to reconfigure to prevent such problems.

About upgrading your KDE I think you should go with what works and what you need.

Best of luck!:wink:

Thank you for replying - I arrived at the same solution, but I ran into permissions problems on my email. Not wanting to risk screwing things up with a ham-fisted chown I put it to one side.

I went to KDE forums where the problem had been more generically identified as being akonadi with the following solution

Remove ~/.local/share/akonadi, ~/.config/akonadi and ~/.kde4/share/config/akonadi* outside KDE.

Solved everything

As for your advice, yes I agree entirely philosophically, but enjoy checking out KDE improvements. While I knew about the nvidia problems, I had never experienced them and I wasn’t expecting to trip up moving from 4.5.95 to 4.6.0