Retracted packages...

Started YaST2 Software Management a few moments ago and instead of opening on the usual “Search” tab it opened on the “Package Classification” tab with a couple of retracted packages listed.

Pretty neat… Description of the feature here:

Hopefully we won’t be seeing it do that too often.

Yes, pretty neat.

And thanks for reporting this here and pointing to the explanation. Better knowing about it before it pops up unexpected…

To me, it seems a bit buggy.

I look at the package. I then check the “Versions” tab, but it does not allow me to select a different version from the one installed. Using “update unconditionally” was the only thing that worked.

(add in edit): neither “zypper up” nor “zypper dup” want to do anything about the retracted package. But after the unconditional update (via Yast), at least “zypper up” doesn’t want me to update to the retracted package.

First YaST > Software > Online Update.

I have two Retracted Packages: timezone and timezone -java. I have no Retracted Installed Packages.

Taking timezone and looking at the Versions tab.
There are two in red: 2020b-lp152.3.3.3-x86_64 and the same for i586 from Update (OSS). Not installed.
Installed is 2020a-lp152.2.1-x86_64 from Main (OSS).

For timezone-java it is similar, but the architecture is only noarch.

To me it looks as my installation is as it should be, but I have no idea if I once had the now retracted packages and that that was repaired later.

For timezone:

I’ve just re-installed the retracted versions to enable me to check this again, as I did select the 152.2.1 version from the versions tab, but what I found was it’s first necessary to select one of the retracted versions and then select the version one wants… so yes, a little buggy. But I’ve seen that behaviour before on the versions tab with results of a search…

Checking here, the bad “timezone” packages were installed this morning (7:20 Chicago time, which should be the same as 1320 UTC). Presumably, they were retracted more recently than that.

In that case I never had them. Updated a week ago and again one and a half hour ago.

Yes, I just tried that, and it works. So a little buggy, but perhaps not worth a bug report for now.

OTOH, they may be happy with all input to improve this feature. And a bug report might be the only way to communicate experiences (or is there a mailing list?).

Thanks for the effort, though I see that it didn’t go anywhere. But it did get some detailed explanation of the thinking involved.

I agree. And let us hope that Paul is right: Hopefully we won’t see the feature too often.