Resume from Suspend/Hibernate not working when running 3D Gnome

I have a Toshiba Satellite L655D-S5093 running openSUSE 12.3 x86_64 with Gnome desktop. My machine has an AMD Turion II P540 CPU, and an AMD RS880M (aka M880G) Chipset, which includes an ATI Mobility Radeon HD 4250. The native resolution of my laptop’s display is 1366x768. I have no noticeable ACPI issues (battery is detected just fine, etc) and I have not seen any artifacts or other screen corruption when running openSUSE, and my UI has been responsive; no noticeable GPU lag. I am using open source video drivers.

I closed the lid of my laptop this morning, causing the machine to suspend-to-RAM, and then opened it an hour later. The screen flashed white very quickly and periodically, but was black most of the time and the machine did not resume successfully; I waited several minutes. I then tried to hibernate, and resuming worked at first, I saw grub, etc, but upon starting the X server, I got the periodic rapid white flashing, without successfully resuming, even after trying for several minutes. I am very lucky that I am not epileptic or I would have had two seizures by now.

I then forced shutdown by holding the power button, powered on again, and immediately forced fallback mode for Gnome, then rebooted again, this time into 2D Gnome. While running 2D Gnome I can suspend/hibernate and resume to my hearts content; I have no issues and everything works perfectly, but it would be really nice if 3D Gnome worked.

Any insights or suggestions are appreciated.

Create a new user, and see if that new user can login on GNOME3. That would nail down the issue to something in your homedir. Report what happens.

I can suspend and hibernate from gnome shell.No problems here

Resuming from Suspend/Hibernate works perfectly on another user, even while running 3D Gnome.

On Wed 22 May 2013 10:26:01 AM CDT, HeWhoIsCalledB wrote:

I have a Toshiba Satellite L655D-S5093 running openSUSE 12.3 x86_64 with
Gnome desktop. My machine has an AMD Turion II P540 CPU, and an AMD
RS880M (aka M880G) Chipset, which includes an ATI Mobility Radeon HD
4250. The native resolution of my laptop’s display is 1366x768. I have
no noticeable ACPI issues (battery is detected just fine, etc) and I
have not seen any artifacts or other screen corruption when running
openSUSE, and my UI has been responsive; no noticeable GPU lag. I am
using open source video drivers.

I closed the lid of my laptop this morning, causing the machine to
suspend-to-RAM, and then opened it an hour later. The screen flashed
white very quickly and periodically, but was black most of the time and
the machine did not resume successfully; I waited several minutes. I
then tried to hibernate, and resuming worked at first, I saw grub, etc,
but upon starting the X server, I got the periodic rapid white flashing,
without successfully resuming, even after trying for several minutes. I
am very lucky that I am not epileptic or I would have had two seizures
by now.

I then forced shutdown by holding the power button, powered on again,
and immediately forced fallback mode for Gnome, then rebooted again,
this time into 2D Gnome. While running 2D Gnome I can suspend/hibernate
and resume to my hearts content; I have no issues and everything works
perfectly, but it would be really nice if 3D Gnome worked.

Any insights or suggestions are appreciated.

Hi
It’s the xf86-video-ati driver. I had to upgrade to the 7.1.0 driver,
see this bug;
https://bugzilla.novell.com/show_bug.cgi?id=799117

If you upgrade it may want to upgrade Xorg, but I updated from the
X11:Xorg repo before the Xorg update.

Is your system up to date? Are you running the default 3.6.x
GNOME-shell? If so I can upload the driver somewhere so Xorg won’t need
updating.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.3 (x86_64) Kernel 3.7.10-1.4-desktop
up 18:48, 3 users, load average: 0.11, 0.10, 0.06
CPU AMD Athlon™ II P360@2.30GHz | GPU Mobility Radeon HD 4200

disable extensions and start up programs and retry with original “user”

After using 2D Gnome for a while and going through several power cycles, I turned off “Force Fallback Mode” and then rebooted to try 3D Gnome again. I tried suspend and hibernating, and I was able to resume properly after doing both. I have deleted the other temporary user I created, and resume still works.

Whatever the problem was, it doesn’t appear to be a problem anymore. If it happens again, I will reply to this thread, either to explain how I fixed it, or to request further assistance.

Thanks much to all of you, sorry for the bother.

Cheers!