Restricted format problem

Hi
I have just installed OpenSuse12.3. I am tryng to install the restricted formats from this page
https://forums.opensuse.org/blogs/caf4926/opensuse-12-3-multi-media-restricted-format-installation-guide-126/
However when i get to the section for KDE i encounter this

here is an update candidate for 'gstreamer-0_10-plugins-good', but it is from different vendor. Use 'zypper install gstreamer-0_10-plugins-good-0.10.31-11.25.x86_64' to install this candidate.
Resolving package dependencies...
3 Problems:
Problem: k3b-codecs-2.0.2-15.40.x86_64 requires k3b = 2.0.2-15.40, but this requirement cannot be provided
Problem: ffmpeg-1.0.6-1.1.x86_64 requires libavutil51 = 1.0.6, but this requirement cannot be provided
Problem: gstreamer-plugins-bad-orig-addon-1.0.7-2.1.x86_64 requires libmpeg2encpp-2.0.so.0()(64bit), but this requirement cannot be provided

Problem: k3b-codecs-2.0.2-15.40.x86_64 requires k3b = 2.0.2-15.40, but this requirement cannot be provided
  uninstallable providers: k3b-2.0.2-15.40.i586[Packman Repository]
                   k3b-2.0.2-15.40.x86_64[Packman Repository]
                   k3b-2.0.2-15.40.i586[packman]
                   k3b-2.0.2-15.40.x86_64[packman]
 Solution 1: Following actions will be done:
  downgrade of k3b-2.0.2-26.1.2.x86_64 to k3b-2.0.2-15.40.x86_64
  install k3b-2.0.2-15.40.x86_64 (with vendor change)
    openSUSE  -->  http://packman.links2linux.de
 Solution 2: do not install k3b-codecs-2.0.2-15.40.x86_64
 Solution 3: do not install k3b-codecs-2.0.2-15.40.x86_64
 Solution 4: break k3b-codecs-2.0.2-15.40.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c] (c): 

What Solution should i select
Thank you

Select “1”.

It is typical to have a few such choices. You are making the choice that switches k3b to come from packman, instead of from the opensuse repos.

Thank you for replying so quickly.
I am do the install as i speak i seem to be getting a similar message for a lot of the
rpm’s, like gstreamer, ffmpeg, vlc to be installed. Is Solution 1 the option for all

Much appreciated, Thank you

Switching vendor to packman is the option for all.

Yes, when I did it, I seem to recall that was always option 1.

Hi
Yesterday I installed OpenSuse12.3. Thank you, nricket for your help, I followed this link:
https://forums.opensuse.org/blogs/caf4926/opensuse-12-3-multi-media-restricted-format-installation-guide-126/
to install the restricted format.
At the end of the installation neither vlc or kaffine could play videos, i tried to play mp4, avi, flv to no avail.
When i try to play vlc i get an error stating “no suitable decoder module”
Kaffine wants me to install more software, when i press OK, it states that it can not find the files in the repositories and wants to make changes.
Why did’nt this work and what can i do to fix it.

Thank you

On 05/16/2013 04:36 AM, Subzero01 wrote:
> I followed this link:
> http://tinyurl.com/c8zohcc

did you do exactly as that blog notes and become root by using this
command:


su -

and, not just su (without the dash “-”)?

did you do that AND have no errors thrown during any operation?

if you are running KDE did you correctly choose to ONLY run the code
designed for KDE (and not those for Gnome, xfce or lxde)??


dd

Thanks DenverD I found the problem, I had to install vlc-codecs

vlc-codecs is included in my guide
so are you sure you followed it?

Have you applied the switch?