restoring files with fwbackups

I just installed 11.2 with a couple of hiccups, but it runs well and looks great. I tried to restore my backup set via fwbackups and it errors out on a python thing. Looked at my python apps (python-crypto in particular) and they are all the latest.

I think one of the two backups I made was a simple copy and not compressed. I’ll try to save the files that way. But this is what I feared most about a backup program: it would backup but not restore.

One important thing: if I try to import the backup set into fwbackups, the dialog box does not put it into the main program when I click “open.” It merely opens the current directory and each click takes it further down the directory tree.

Luckily, I was able to drag & drop my docs back. Didn’t try to get everything though. I would like to restore a backup just once! :stuck_out_tongue:

Let us know how you’re getting on. I’m in search of a backup solution too and trying out fwbackups too. Have just persuaded it to backup to a mounted network drive (without SSH) but not tried a restore yet…

Can’t overcome a python error when I try to import the set (saved backup) into my 11.2 install. However, all the files were there in the backup and I used Dolphin to copy them into the Documents folder of my new install.

It works but it should not be this way.

Hi
Can you post the python error and maybe run strace and pot the output
to pastebin or nopaste. Also are you using 32, 64bit, KDE or Gnome?


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
up 2 days 19:45, 2 users, load average: 0.06, 0.08, 0.08
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

hmmm… more suse voodoo :stuck_out_tongue:

I can’t duplicate the problem. After the last reboot (about 4th since install) I suddenly have to login with my password and fwbackups seems to be restoring. It’s been running 10-15 minutes and not reporting an error.

I really don’t understand this at all. I have noticed in many suse versions, going back to 10.3, that it takes more than 1 reboot to get an effect. Its as if it needs a few reboots to settle down.

Don’t know how long this will take, but I’ll give a report when its over.

I didn’t time it, but it took about a half hour to restore my files. It didn’t go where I wanted but that isn’t such a big problem. My docs now reside in /home/home/Documents.

Since I had a problem with the install of 11.2, I am thinking I will blow the whole thing out and start over. As I said, this is confusing to me. I did nothing, not even updates, and after several reboots, the problem went away. It was still present after 2 reboots for sure.

A general question: do I want to restore anything from 11.1 but docs? I had a problem with compressing the backup of /home taking 26 hours. Now, I’m not sure if I should restore it. Won’t it bring in files from 11.1 that I don’t want? I’m thinking I only want that if I want to go back to 11.1, right?

BTW, now that it works, fwbackups seems like a good solution… except for that compression problem.