Restart Options

recently I installed openSUSE 11.2 with KDE. the first time I boot, I noticed that in the exit tab, the option to restart had few “options” [kind of a menu] to automatically restart on any operating system I have in my GRUB … but now those options disappeared,:expressionless: and the option to restart just sends me back to my GRUB. :frowning:

someone could tell me what happened? and if there is a way to retrieve these options?

Thank you! lol!

I fairly certain they have been removed. There was a discussion about it some time ago, but I can’t recall the details. And I would never use this function anyway, personally.

Are you sure? They are still there as far as I can see, on this machine where I’ve just installed 11.2. There’s an down arrow on the Restart button and if you hold down the button you will get a dropdown list of images and you can choose one to be the next OS to boot. Very handy on dual boot machines if you want a non-default OS and you don’t want to hang around to catch GRUB before it times out and boots the default.

Look again.

Are you gnome though @ken_yap

I’m on KDE, as is the OP.

I’m with Ken, kde4 as well, the options were certainly there, until Mr Gates borked my system yesterday (A “Help!” post is on its way!!!)
However they did not QUITE work, as for some reason I now have (or did have…) TWO GRUB menu’s. So I boot, 11.2 grub menu, I select 11.1, and up came 11.1’s menu,

You must have another GRUB installed in the partition boot sector which is chained to from the master GRUB.

This is normal
If you look at the details in 11.2 it’s entry to boot 11.1 with part of the entry like this

configfile /boot/grub/menu.lst

That fires up 11.1’s grub menu

Any news on this?

It also definitely worked for me after a fresh 11.2 install, but somehow this option is gone now and I cannot recall when this option was lost (i.e. what caused it to be lost).

The restart option is really useful:* I set GRUB to boot suse11.2 within 1 second, since I almost always boot suse11.2. However, once a month I might need need Windows for updating some devices that do not have a Linux driver (BIOS, GPS, HarmonyRemote, etc.).

RESOLVED for me: rotfl!

KDE4-> SystemSettings -> Tab:Advanced -> LoginManager -> Tab:ShutdownOptions -> DropDown:BootManager -> Grub.

Note: I needed to reboot before that change had any effect (probably logging out of KDE suffices too).

I do recall that I changed some settings for the LoginManager. I also recall that these changes broke other things, such as an icon for account “root” appearing. The boot loader preference appears to be another one which is not picked up from the current configuration. So I guess the default options offered are not the current settings - or at least the special settings obtained after a fresh install.

The Google search had pointed to KDM to the source of the problem, so looked at that Login Manager setting more carefully now.


It was already given. When you click restart or even ctrl+alt+delete, the restart box has a little down arrow/triangle on it. All you have to do is click the option you want to choose (in this case restart) but keep the mouse button held down. A new menu will appear with your Operating System options to boot up after restart.

Take Care,


If your interested there is the grubonce command.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 2 days 0:49, 2 users, load average: 0.34, 0.34, 0.20
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

The problem (for me - and as far as I can discern for the original poster as well) had been that this little triangle had disappeared mysteriously. Click+Hold would not present any choices anymore, just restart.

Anyway, it is resolved now and I got my little triangle back! :slight_smile: