Restart options gone kde?

Odd - the little drop-down (arrow and all) is gone from the little dialog box that KDE/Leave/Restart brings up for choosing which system to restart when restarting my dual-boot system. I checked out the KDE bootloader applet and all seems correct. The little down-arrow (and its options) are still there for Shutdown - just not for reboot. I did some googling of this, and there appear to be some issues, but no definite fixes. Does this sound familiar to anyone


That’s a convenient option that I haven’t seen in other OS’s.


Hi, I have a multiboot system including 11.4 & 12.2, both with KDE and both in extended partition.

12.2 KDE: Restart has the arrowed dropdown; it is set as the default entry for booting in the grub boot loader (legacy).
11.4 KDE: Restart does NOT have the arrowed dropdown; and is NOT grub’s default entry.

When 11.4 KDE was the grub default entry, its Restart did have the arrowed dropdown list.

What is “KDE bootloader applet”? I’m only aware of YaST > System > Boot Loader for managing the configuration.

Glad this is here for reference - I fixed it on one box, then it happened on another! Odd. I guess KDE is still evolving at a rapid rate.

This has nothing to do with KDE evolving.
KDM’s default bootloader setting is “None”, that means you have to explicitly specify the bootloader you are using in System Settings > System Administration > Login Screen -> Shutdown to have that Restart-menu.

On openSUSE, KDM was patched to use grub as default, so you had the Restart options even on a fresh install.

Then came openSUSE 12.2 and the default bootloader was changed to grub2.
But it was forgotten to change the patch for KDM to “Grub2”…
On upgrade you wouldn’t notice it, because you would still use grub(1), but when you install 12.2 from scratch the restart options are not there.

I noticed this in February and wanted to fix this for 12.3, but I was a bit too late, the new default didn’t make it into 12.3 GM.
But: in the KDE online update to 4.10.2 which was released a few days ago, the default is grub2 now, so on a freshly installed 12.3 it should work again out of the box after installing the online update…:wink:

But of course you still may need to adjust it in System Settings > System Administration > Login Screen -> Shutdown…

Thanks, interesting and explains my current loss of restart options. :slight_smile: I was just about to investigate it with my multiboot setup, having introduced a 12.2 and 12.3 with grub2 into the mix with others using grub legacy.