restart into option

hello iv been using suse since about the 9.3 days

and i run multiple versions of suse and other OS’s

as of the last month or 2 if been having some problems with the restart option and grub.

i used to be able to use the restart dialog in KDE to select which OS’s i want to restart into instead of having to wait for grub to give me the boot selection screen but now that restart to OS option in KDE does nothing but is still there.

iv been right through the grubs menu.lst and through the boot loader stuff in yast and haven’t figured out why this stopped working as expected or how to fix it.

just want to know if anyone knows the fix or shares the same problem.

im running

openSuSE 11.2
kernel: Linux 2.6.31.12-0.2-desktop x86_64
KDE 4.4.3

thanks

Hello eagles500,

The problem is that KDE doesn’t know which bootloader you use.
So KDE can’t provide this feature.
There’s a simple way to tell KDE which bootloader you use.
Go to System Settings->Advanced->Login Manager.
Select the shutdown tab.
You’ll see “Boot manager: [None]”.
Click on the pull-down menu to change it to Grub.

It’s strange that it suddenly didn’t work.
Maybe it was a update?

Good luck!:wink: