resolv.conf wird nicht aktualisiert

Hallo,
um die dämliche T-Online-Navigationshilfe zu umgehen, wollte ich die Liste der DNS-Server aktualisieren.
Folgende Server sollten dabei aufgenommen werden: 213.73.91.35 151.236.10.135 204.152.184.76 5.9.28.125
Über den Editor für /etc/sysconfig/ habe ich unter Network > General > NETCONFIG_DNS_STATIC_SERVERS diese eingetragen.
Änderungen gespeichert.
Aber: die resolv.conf wird nicht neu geschrieben.
Den Tipp mit der Änderung für NETCONFIG_DNS_POLICY von auto auf “* STATIC_FALLBACK NetworkManager” habe ich auch ausprobiert.
Hat auch nichts gebracht.
Test-URL www.opennic.glue

System OpenSuse 12.2, aktuell.

Wer kann bitte helfen?

In /etc/resolv.conf sagt es


### /etc/resolv.conf file autogenerated by netconfig!
#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
### Please remove (at least) this line when you modify the file!
### /etc/resolv.conf file autogenerated by netconfig!
#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
### Please remove (at least) this line when you modify the file!




Ich würde /etc/resolv.conf wegschmeißen (wird neu gemacht), und dann Yast benützen um den DNS servern zu ändern.

Danke, aber über YaST habe ich ja den Editor für /etc/sysconfig/ aufgerufen.

Rufe bitte “netconfig update -v” auf um zu schauen was da genauer passiert bzw. “netconfig update -v >/tmp/netconfig.log” um die Ausgaben in eine Datei zu schreiben.
Mit “netconfig update -f” kann man das Schreiben der Dateien forcieren.

Ausgabe von “grep ^NETCONFIG /etc/sysconfig/network/config” ist auch Sinnvoll um sich ein Bild von der Konfiguration zu machen.

BTW:
Bei NETCONFIG_DNS_POLICY="* STATIC_FALLBACK NetworkManager" werden NetworkManager nameserver benutzt, es sei denn dieser liefert keine.
Bei “* STATIC NetworkManager” haben die von ifup gelieferten vorrang, bei “STATIC * NetworkManager” werden auf jeden Fall die statischen genommen.