Resolution setting not working since update 11.0->11.1

Hi,

since update of opensuse 11.0 to 11.1 on my notebook, the native screen resolution of 1400x1050 is not set anymore. Instead it is 1280x960. Sax2 shows the correct one 1400x1050, but even in test mode for this setting, 1280x960 is chosen.
This is really annoying and time-consuming, especially regarding the fact that the correct resolution worked automatically after 11.0 installation.
The xorg.conf seems to be ok in my eyes, also tried sax2 -r and removing other modes for 24bit. Here it is (unmodified after update):
Section “Files”
FontPath “/usr/share/fonts/misc:unscaled”

FontPath “/opt/kde3/share/fonts”
InputDevices “/dev/gpmdata”
InputDevices “/dev/input/mice”
EndSection

Section “ServerFlags”
Option “AllowMouseOpenFail” “on”
Option “ZapWarning” “on”
EndSection

Section “Module”
Load “freetype”
Load “type1”
Load “dbe”
Load “glx”
Load “extmod”
Load “dri”
EndSection

Section “InputDevice”
Driver “kbd”
Identifier “Keyboard[0]”
Option “Protocol” “Standard”
Option “XkbLayout” “de”
Option “XkbModel” “microsoftpro”
Option “XkbRules” “xfree86”
Option “XkbVariant” “nodeadkeys”
EndSection

Section “InputDevice”
Driver “synaptics”
Identifier “Mouse[1]”
Option “Buttons” “5”
Option “Device” “/dev/input/mice”
Option “Emulate3Buttons” “on”
Option “HorizScrollDelta” “0”
Option “InputFashion” “Mouse”
Option “Name” “Synaptics;Touchpad”
Option “Protocol” “explorerps/2”
Option “SHMConfig” “on”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”
EndSection

Section “InputDevice”
Driver “mouse”
Identifier “Mouse[3]”
Option “Buttons” “5”
Option “Device” “/dev/input/mice”
Option “EmulateWheel” “on”
Option “EmulateWheelButton” “2”
Option “InputFashion” “Mouse”
Option “Name” “IBM;TPPS/2 TrackPoint”
Option “Protocol” “explorerps/2”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”
EndSection

Section “Monitor”
DisplaySize 287 215
HorizSync 30-90
Identifier “Monitor[0]”
ModelName “1400X1050@60HZ”
Option “DPMS”
Option “PreferredMode” “1400x1050”
VendorName “–> LCD”
VertRefresh 50-60
UseModes “Modes[0]”
EndSection

Section “Modes”
Identifier “Modes[0]”
EndSection

Section “Screen”
DefaultDepth 24
SubSection “Display”
Depth 15
Modes “1400x1050” “1280x1024” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 16
Modes “1400x1050” “1280x1024” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 24
Modes “1400x1050” “1280x1024” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 8
Modes “1400x1050” “1280x1024” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
Device “Device[0]”
Identifier “Screen[0]”
Monitor “Monitor[0]”
EndSection

Section “Device”
BoardName “Radeon LY”
BusID “1:0:0”
Driver “radeon”
Identifier “Device[0]”
Option “CRT2VRefresh” “50-60”
Option “MetaModes” “1400x1050,1024x768;1024x768,1024x768”
Option “IgnoreEDID” “yes”
Option “CRT2HSync” “31-48”
Option “MergedFB” “yes”
Option “GARTSize” “32”
Option “CRT2Position” “Clone”
Option “MonitorLayout” “AUTOCRT,AUTO”
Screen 0
VendorName “ATI”
EndSection

Section “ServerLayout”
Identifier “Layout[all]”
InputDevice “Keyboard[0]” “CoreKeyboard”
InputDevice “Mouse[1]” “CorePointer”
InputDevice “Mouse[3]” “SendCoreEvents”
Option “Clone” “off”
Option “Xinerama” “off”
Screen “Screen[0]”
EndSection

Section “DRI”
Group “video”
Mode 0660
EndSection

Section “Extensions”
EndSection

Maybe someone has some hints for me.
Thanks in advance
vbar

Seems to be a problem of the radeon module; using vesa it’s no problem to use 1400x1050. As vesa is not very performant nor has 3d support, it’s rather a temporary solution.

vbar