Resolution issue with GeForce4 MX 440 with AGP8X

I have an iiyama Vision Master Pro 400 monitor. It has the following specs:

Sync Frequency: Horizontal: 27.0-96.0kHz, Vertical: 50-160Hz
Video Bandwidth: 160MHz dot clock

My video card as mentioned in the title is a GeForce4 MX 440 with AGP8X with 64MB RAM.

Under Windows XP I’m able to achieve a resolution of 1024x768@100Hz, but in Linux the maximum I can attain is 1024x768@75Hz. No mater what screen size I select, I can’t get more than 75Hz. I followed the Nvidia Installer HOWTO for Suse and installed the x11-video-nvidia package.

Any ideas?


Open a console type su then root pass then
nvidia-xconfig then nvidia-settings set you resolution and save to xconfig.

I ran the command nvidia-settings. In the X Server Display Configuration, the only resolutions available are Auto, 75Hz, 70Hz and 60Hz.

Try adjusting xorg.conf manually. Backup your current working xorg.conf before editing with something like

cp /etc/X11/xorg.conf /etc/X11/xorg.conf.working

That way you can reinstate it if required.

  1. Add a modeline to beginning of ‘Modes’ section:

Modeline “1024x768_100.00” 113.31 1024 1096 1208 1392 768 769 772 814 -HSync +Vsync

  1. Then set ‘PreferredMode’ in ‘Monitor’ section:

Option “PreferredMode” “1024x768_100.00”

  1. The ‘Screen’ section has some modes listed. Make sure the preferred mode is listed first like this example:

Section “Screen”
DefaultDepth 24
SubSection “Display”
Depth 15
Modes “1024x768_100.00” “800x600” “768x576” “640x480”

You may also need to disable EDID and frequency detection, so that your xorg.conf settings are used instead. Add this to ‘Device’ section:

Option “UseEdidFreqs” “0”
Option “UseEDID” “false”

Take care with the syntax while editing. Hoepully this will work for you. Post your xorg.conf if you need further help.