resolution bugs


I’ve a little problem when i start my new openSUSE 11.4. (I use linux first time.)
When i booted the system, every icon and thing in the desktop is bugged and flashing. Above all these things are unusable, because if i pull the cursor over the “startmenu” or everything else, it starts flashing and i can’ use it.
I thought that the problem is with the resolution 1600x1200, and my monitor’s maximum res. is 1024x768. I tried to change it but it was useless.
Every time i changed the res to 1024x768, for a moment, or two everything was in the good position, but a sec. later the ~60% of the screen turned black and i can only see something in the remaining ~40%. Other resolutions were even worse, like 800x600 or smaller, and a lots of other res. the whole screen was black.
And every restart the configuration lost.
What can i do?

Intel Celeron 2.6ghz x2
other os: windows xp 32bit
1gb ddr2 ram
intel extreme graphics 2 vga
, so it’s not the latest pc.

Sorry for my bad english…

Use the following boot option:


That should change the graphics driver from “intel” to “fbdev”, an inferior driver but you should get only 1024x768. Hopefully that will give you a system you can work with.

Post back with the result, and then we can tell you how to configure permanently for that resolution but using the “intel” driver.

The desktop is not reached after boot, but later, after a login (that logiin can be automatic). And when a user loged in, his desktop is of a certain type. This can be KDE, Gnome, many others. Would be nice when you told us which desktop environment this user (you?) uses.

I’m using KDE plasma and i said that i’m using linux first time, so where can i set the boot mod to ‘nomodeset’?

When you boot, at the boot screen, do like this shows

File:Nomodeset-example.jpg - openSUSE

So, i tried typing the ‘nomodeset’ after the ‘vga=0x314’ or something that was there, but the resolution was the same 1600x1200 in addition that ‘nomodeset’ disabled the resize of the screen. Fortunately the user interface worked fine.
Second try: I restarted the system and at the boot menu i overright the ‘vga=…’ with nomodeset, after that the system booted the same res. but i was able to resize it and now the screens 60% wasn’t black.
Now, there are an another problem: the 1024768 and all other res. except 16001200 are deformed…
What can i do to solve these problems?
Thanks in advance for the help. :smiley:

With nomodeset, the boot will proceed as before (1600x1200) but without the kernel doing mode setting. When X system loads the “fbdev” driver, then the resolution should change to 1024x768 (maybe deformed). Assuming you don’t change anything further, after the login stage you should arrive at a working desktop displayed at a resolution of 1024x768. Does that happen as I describe it?

Please confirm that is the case.

After the login with nomodeset, after all i configured the res. to 12801024 and i positioned it to the right place with the monitor’s buttons. Than i saved it and sat it to default… everything was good. shutdown–>login with default kde plasma and the 16001200 was there–>shutdown–>boot with nomodeset and the problem is the same.
I’am totally beginner t linux, so i know nothing, what wrong i did.

NEWS: Nows, if i login and only login with nomodeset, everything is good.
Thanks everybody for the help!!!
A last little question: how can i set, that the default login will be good too?

‘A new Linux user…’ :smiley:

That’s good news. The answer to your “little question” could involve you in editing some configuration file(s). Are you familiar with doing that, using a graphical editor (e.g. kwrite) on the KDE desktop? Also:

intel extreme graphics 2 vga
, so it’s not the latest pc.

Can you tell us if that integrated graphics chip is on an Intel 852 or 855 chipset?

Where can i find that what’s the type of my video card? I searched it ecerywhere, like Windows and Linux device manager, the motherboard and the bios menu.
I only found something like that: 775i65g ; intel 82810 ; 82865 ; 82848…
So, i really need some help about that too…

On 03/31/2011 07:06 PM, szpeter96 wrote:
> Where can i find that what’s the type of my video card?

click on the MyComputer icon on your desktop, there you will find what
graphics you have as well as what driver is being used…

Tried LibreOffice? Do that and help at
[NNTP via openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8]

But if i open the my computer, there isn’t any 852 or 855, only 865g, is it good?
The whole thing is not so important because i can use the whole system, but it’s a little uneasy.

If that doesn’t show it, run this command in Terminal/Konsole:

/sbin/lspci -nnk

Post back with the first few lines of the results to include info about VGA and Display controllers. Highlight and copy the lines from Terminal. You must post them by wrapping those lines in CODE tags (I did that posting the above command). To do that, reply by “Go Advanced”, paste the text, highlight the text block, and click on the “#” icon to insert the CODE tags. Complete the posting as normal.

It could be, but anyway please post results of above command as described in my post #13.

865g is probably the integrated video adapter on 852/855 chipset.

00:00.0 Host bridge [0600]: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface [8086:2570] (rev 02)
        Subsystem: ASRock Incorporation Device [1849:2570]
        Kernel driver in use: agpgart-intel
00:02.0 VGA compatible controller [0300]: Intel Corporation 82865G Integrated Graphics Controller [8086:2572] (rev 02)
        Subsystem: ASRock Incorporation Device [1849:2572]
00:06.0 System peripheral [0880]: Intel Corporation 82865G/PE/P Processor to I/O Memory Interface [8086:2576] (rev 02)

Is this good?

It is important info. That is the Intel® 82865G Graphics and Memory Controller Hub (GMCH). It appears to be the integrated display adapter of the 865G chipset, and not the 852/855 chipset.

It is supported by the “intel” graphics driver according to its man page. If it only works with “nomodeset” then there is either a problem with the Kernel Mode Setting or the “intel” driver at its current release level.

An older version of the intel driver is available and referred to as the “intellegacy” driver. Its package should be installed by default, and named as “xorg-x11-driver-video-intel-legacy”. You can check by issuing (in terminal) the command: zypper se intel-legacy. An “i” in the left-hand column will confirm it as installed.

To load “intellegacy” driver at startup, you should edit (as root e.g. using kdesu) the file /etc/X11/xorg.conf.d/50-device.conf to add this line:

 Driver "intellegacy"

For example:

Section "Device"
  Identifier "Default Device"

  #Driver "radeon"

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"

  Driver "intellegacy"


Save, and restart/reboot to load the new driver.

Post back with any questions, or the results of booting with “intellegacy”.

I added the line to my file, the blinking, bugged menu bug stopped, I logged in with normal boot, but if I want to change the resolution down from 1600*1200, a percentage of my screen becomes black and unusable… (I tried it with “root” and “myusername” too).
What can I do?

The improvement is good news. For the resolution, to get for example your native mode of 1024x768, try the following edit in another xorg.conf.d file:

Add/insert the following lines to file 50-screen.conf immediately after the line: Identifier “Default Screen”

  SubSection "Display"
  Depth 24
  Modes "1024x768"

You may end up with this resolution, but at the wrong refresh rate. If so, try to reach System Settings>Display and select another “Refresh” rate if available (or use xrandr via the commandline?).

Plaese let us know how it goes.

Thanks for the help, it works correctly.
Unfortunately, after the UI became good, I tried to use internet and others…
It isn’t a bug, but I need help.
I can’t use the internet, or play music, etc…
This is my motherboard.
ASRock > Products > 775i65G
And also I have a D-Link DWL-G122 wlan adapter.
I haven’t found any linux driver and i haven’t got cd with drivers.
So, where can I find good, usable drivers for my computer?

There is still no internet on my computer, but ecery time I opened the auto-installed firefox 4 suddenly the linux logged me out. Why was that?