Resoluition Issues

I just switched to opensuse a couple of days ago and I noticed that my resolution was stuck in 800x600. I went and downloaded the nvidia drivers and went to install the driver for my monitor through sax2. When I tried to add the monitor driver I would get out of range errors. I rebooted and can now set the resolution to 1680x1050 which is my max. However, when I go to test these new settings the resolution shown in the window is 1400x1050.

GPU: Nvidia GeForce 9600 GTX

What can I do to fix this?

Install the driver properly out of X at level 3 boot

Alright so here is how to install the nvidia driver manually, in case the one in the repo doesn’t work or u just want to use the latest.

Go to Yast>Software>Software Management

Search for and install if you don’t have these:


Now download the latest Nvidia driver:

Place the file in your /home/username

Now restart and at the boot screen, pause the boot by moving the down button, then move back up and clear any text in the boot arguments by holding backspace. Then just type the number: 3
At the login
Login with your username and password

Now switch to super user with su
and root password

*Now remember you can use the {TAB} key to auto complete

so type:
and the whole file name should auto complete

eg: sh

Follow the installer and let it compile the kernel module for you.
Say Yes to everything
Use TAB to move around

I did all of the above and still having problems.

Do you have a /etc/X11/xorg.conf file?

If you do, try a level 3 boot, login as user, become su and do this

cd /etc/X11


mv xorg.conf xorg.conf.bak



Alright. Back to Small res. Whats next?

I suggest you take a long look here
openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

I had a good long read. Tried a few different drivers. I am getting the best res with the proprietary driver. All my settings show 1680x1050. But my screen res is still stuck at 1400x1050, as it shows on the res test :frowning:

I was working with a 9800GT the other day, it worked perfectly from default install.
Then I installed the Propriety nVidia driver. Now its all the business.
I can’t see why yours should be different.

I had a good long read. Tried a few different drivers. I am getting the best res with the proprietary driver. All my settings show 1680x1050. But my screen res is still stuck at 1400x1050, as it shows on the res test

Please post the output of


Can you using the nvidia driver? This might help you confirm:

openSUSE Forums - View Single Post - openSUSE Graphic Card Practical Theory Guide for Users

Other problems notwithstanding, it is possible that your display device is sending incorrect EDID which will confuse the driver.

Output of xrandr

Screen 0: minimum 320 x 240, current 1400 x 1050, maximum 1400 x 1050
default connected 1400x1050+0+0 0mm x 0mm
   1400x1050      50.0*    57.0
   1280x1024      51.0     58.0
   1280x960       52.0
   1152x864       53.0
   1024x768       54.0     59.0     60.0
   800x600        55.0     62.0     63.0     64.0
   640x480        56.0     67.0     68.0
   832x624        61.0
   700x525        65.0     66.0
   512x384        69.0     70.0
   400x300        71.0
   320x240        72.0     73.0

Thanks rankfourteen. I’m assuming you are using the nvidia driver (as opposed to the nv driver), and you have no /etc/X11/xorg.conf present. The xrandr results show the available display modes as reported by your monitor via EDID. (Your /var/log/Xorg.0.log file might show evidence of this). As caf4926 mentioned it should just work, but your display device can be the problem here.

It is possbile (but normally not necessary) to use a working xorg.conf file, disable EDID, and add entries for the desired diplay resolution, along with the custom modeline. (You can use gtf to generate these).

Option “UseEDID” “False”

If you have a DVI connected monitor, you may also need to include

Option “ExactModeTimingsDVI” “TRUE”

This is a good reference:

Modeline Database - MythTV

If you need further help with this, I recommend you post your xorg.conf to pastebin and include URL here.


I’m only used linux for a few weeks now and i had some problem with saving my nvidia setting and i found this.

I followed what the instruction said then when with install “make, gcc, kernel-source” and after i rebooted the computer my computer boot up to text mode
"Welcome to openSUSE 11.2 “Emerland” - Kernel (tty1)

Linux-blg7 login:"

I can’t find a way to get to graphic mode… What do i have to do?
I have tried with sax2 that i found on an other post but it didn’t help.

Please help me.

What happens if you choose failsafe at boot?

Same thing. I only get into the text mode

Tell us more about your system, particularly the graphics card and if you have installed the drivers. If it was working before, what did you do when it stopped working? (Other than install: make, gcc, kernel-source)

I got a geforce 6800. I had installed nvidia driver from this site from get software, but i had a problem that resolution was 1024x768 and i wanted 1280x1024. i could cange the settings in nvidia settings and i worked fine but i could not save the settings.

Every time i tried to save to x file it freeze and noting happend. i notice that there was no /etc/X11/xorg.conf so i wrote touch /etc/X11/xorg.conf so there would be one but then nvidia setting said can’t parse the existed /etc/x11/xorg.conf.

then i notice this post so i thought i should try it, and so i did.

i downloaded the latest driver from nvivida site and installed the stuff and did the instruction you said. and when i rebooted and i got stuck in text mode.

Please try this.
At the login - Login with your username and password (the password does not display as you type)

Now become su
To do this type: su -
then your root password

Now type this:

mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

Now type: reboot

What happens now

nothing happend… I’m still stuck in text mode

Do the same thing and get to where you are su -

and do this

sax -r -m 0=nvidia

That’s a zero=nvidia not a letter O


I get something wrong…
It says “If ´sax´ is not a typo you can use command-not-found to lookup the package that contains it, like this: cnf sax”