Resizing windows xp

Hello everybody

I posted this question somewhwere else 2 days ago ,and did not receive any help from nobody and then i realized that i posted this question as an answere to someone else’ question,so,that’s why i moved it here ,hoping to get some answeres to my question.

recently ,i installed opensuse 11.1 on my dell desktop with windows xp on it.

I really do not know anything about partitioning.Today when i was trying to download a programm on windows xp,i kept receiveing an error message ,that was reading “NOT ENOUGH DISK SPACE”.

after digging thru different posts,i learned to check how much space i have on different partitions and realized that from 80 GB hard disk that i have ,only 9 GB of it was given to windows, and the rest was given to linux in the form of sda2,sda3,sda4 and sda5 that i really have no idea what they are .

All i want now is, to make the windows partition much bigger (at least 50 gb), and i do not know how to do this.

can somebody please help me regarding this issue and explain it with the language that is understandable for newbies.

Thank you all.

Try burning a Parted Magic Live CD. Browse website.
Boot with it, and start the Graphical Partitioner tool.
Shrink a partition next to the XP one.
Grow the XP partition to use the freed space.
Reboot normally and enjoy.

Hello again

I did follow the instruction regarding parted magic live cd and this is what happened.

as you said ,i shrunk the partition next to the xp from 40 GB to 10 GB and after that when i went to grow the windows xp ,it did not let me do anything and i thought may be i have to reboot and do it again, so when i powered the computer on and tried to boot , i saw is reading “NO BOOT DEVICE AVAILABLE” and basically is stucked in bios and going nowhere without doing any normall boot to windows or opensuse or anything.

i tried so many different shut down and power on and is doing nothing .

computer starts with dell logo in bios version and when i try anything like normall hard disk booting or usb cd rom or hard drive diagnosting,the answere is the same ,
DEVICE IS NOT AVAILABLE, and i really do not know what to do.
please ,let me know ,what do i need to do to fix this problem and at least can boot normally either to windows or opensuse .

thanks. mike

You may have shrunk the partition with the boot loader code in it, so now it can’t find the blocks to run the boot program into memory that reads the ondisk format and menu file…

You’ld need to re-install grub, simplest now, into the MBR giving the device of your boot partition. There’s other threads and info in forum covering GRUB installation.

You won’t have done anything “serious” with Parted Magic, to stop the machine working.

If drives aren’t registering, sometimes reseating cables helps. It would be an unlucky coincidence.

I don’t understand why you could boot with Live CD-ROM before and not now. If that’s the case, check BIOS boot sequence, and get CD-ROM boot working, without that there’s nothing you can do.

I tried everything to make it boot from anything including cd rom,but unfortunately i keep receiving “NO BOOT DEVICE AVAILABLE” and really leaves me no other option to boot.

You are quite certain that the optical drive is configured as first boot device in bios setup?