Resizing a RAID1 partition?

It’s exceedingly cool that openSuSE11.0 automatically recognizes my nVidia RAID chip and offers to install on the md0 (I think that’s the device name it used) - but now I’m in a bit of a pickle - I need to resize my SuSE partition to make room for another OS, but my normal tool GPartEd doesn’t recognize RAID. I tried the Repair function on the 11.0 DVD but couldn’t find the partitioner on there. It looks like the suse YaST partitioner may do the job - do I need the “Live” version of the 11.0 DVD?

My current partition setup is on a 400GB drive pair and occupies the entire space:
/ 100GB
/home 150GB
/scratch 150GB

… so to install another OS, I think I can just remove /scratch from fstab, but I’d also like to shrink /home to something like 100GB (GParted will move partitions around but the yast partitioner won’t.)


…OK, I think I can just delete the scratch partition in the YaST partitioner, then login as root and resize the /home partition. I think YaST is smart enough to non-destructively resize the home partition, right? Then, afterward, I can reinstall the 11.0 bootloader and chain-load the other OS. Can someone give me a reading on how this sounds before I do it?

BTW… the RAID is /dev/mapper/nvidia_afecfajc

Hmmm … The YaST partitioner “might” be able to move partitions around if you first unmount your /home and move it to your root partition. “Maybe” that can be done on a live partition, haven’t tried yet. Say, you create /home dir in your root partition, copy all the data from your current /home there, add a new stanza to your fstab, unmount the old /home, and then mount the new one. Once you have this situation, you don’t need to mess up with resizing (it’s a very lengthy process): you can now simply delete both /scratch and old /home and create any partitions of any size in their place… I think:P

I think the trick is to boot from the Live CD and do it. I was just a little worried that the data actually on the partition I’m resizing doesn’t get messed up. Then I got a brain-storm and thought, “Why not use Xen?” So that went well, except I can’t get the machine to recognize more than 8 CPUs (there are 32 on my system). I know it’s not the OS (Win2003serverEnterprise) because it’s installed on a 16CPU system and sees them all. So it’s a problem with Xen somehow. (I have Xen set to provide 16 CPUs)