Reset usb system

I had a crah when pluging a usb wireless. Here it is:


2014-10-10T00:18:33.748838+02:00 andromeda kernel:  1236.534522] usb 2-3: new high-speed USB device number 2 using ehci-pci
2014-10-10T00:18:33.868641+02:00 andromeda kernel:  1236.652020] usb 2-3: New USB device found, idVendor=0bda, idProduct=8172
2014-10-10T00:18:33.868682+02:00 andromeda kernel:  1236.652026] usb 2-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
2014-10-10T00:18:33.868686+02:00 andromeda kernel:  1236.652029] usb 2-3: Product: RTL8191S WLAN Adapter 
2014-10-10T00:18:33.868690+02:00 andromeda kernel:  1236.652032] usb 2-3: Manufacturer: Manufacturer Realtek 
2014-10-10T00:18:33.868693+02:00 andromeda kernel:  1236.652034] usb 2-3: SerialNumber: 00e04c000001
2014-10-10T00:18:33.870449+02:00 andromeda mtp-probe: checking bus 2, device 2: "/sys/devices/pci0000:00/0000:00:13.2/usb2/2-3"
2014-10-10T00:18:33.871139+02:00 andromeda mtp-probe: bus: 2, device: 2 was not an MTP device
2014-10-10T00:18:33.874869+02:00 andromeda kernel:  1236.661620] r8712u: module is from the staging directory, the quality is unknown, you have been warned.
2014-10-10T00:18:33.875847+02:00 andromeda kernel:  1236.662630] r8712u: Staging version
2014-10-10T00:18:33.875887+02:00 andromeda kernel:  1236.662749] r8712u: register rtl8712_netdev_ops to netdev_ops
2014-10-10T00:18:33.875897+02:00 andromeda kernel:  1236.662760] usb 2-3: r8712u: USB_SPEED_HIGH with 4 endpoints
2014-10-10T00:18:33.877839+02:00 andromeda kernel:  1236.664018] usb 2-3: r8712u: Boot from EFUSE: Autoload OK
2014-10-10T00:18:34.601653+02:00 andromeda kernel:  1237.388535] usb 2-3: r8712u: CustomerID = 0x0000
2014-10-10T00:18:34.601685+02:00 andromeda kernel:  1237.388542] usb 2-3: r8712u: MAC Address from efuse = 00:1f:1f:ef:72:3f
2014-10-10T00:18:34.601688+02:00 andromeda kernel:  1237.388546] usb 2-3: r8712u: Loading firmware from "rtlwifi/rtl8712u.bin"
2014-10-10T00:18:34.601691+02:00 andromeda kernel:  1237.389211] usbcore: registered new interface driver r8712u
2014-10-10T00:18:34.602998+02:00 andromeda kernel:  1237.390290] usb 2-3: r8712u: Firmware request failed
2014-10-10T00:18:46.711148+02:00 andromeda kernel:  1249.514156] usb 2-3: USB disconnect, device number 2
2014-10-10T00:18:46.711191+02:00 andromeda kernel:  1249.514372] BUG: unable to handle kernel paging request at 0000000000003ee8
2014-10-10T00:18:46.711215+02:00 andromeda kernel:  1249.514380] IP: <ffffffffa144a23f>] r871xu_dev_remove+0x2f/0x110 [r8712u]
2014-10-10T00:18:46.711219+02:00 andromeda kernel:  1249.514403] PGD 0 
2014-10-10T00:18:46.711221+02:00 andromeda kernel:  1249.514409] Oops: 0000 #1] PREEMPT SMP 
2014-10-10T00:18:46.711225+02:00 andromeda kernel:  1249.514417] Modules linked in: r8712u(C) nls_iso8859_1 nls_cp437 vfat fat usb_storage rfcomm vmnet(O) parport_pc vmw_vsock_vmci_transport vsock vmw_vmci vmmon(O) nimxdfk(PO) vboxpci(O) vboxnetadp(O) vboxnetflt(O) vboxdrv(O) fuse rpcsec_gss_krb5 auth_rpcgss oid_registry nfsv4 nfs fscache lockd sunrpc af_packet nipxirmk(PO) nidimk(PO) nimdbgk(PO) niorbk(PO) bnep nipalk(PO) nikal(PO) binfmt_misc nvidia_uvm(PO) nvidia(PO) snd_hda_codec_hdmi joydev kvm btusb serio_raw pcspkr bluetooth k10temp rfkill edac_core edac_mce_amd sp5100_tco snd_hda_codec_via ppdev i2c_piix4 snd_hda_intel snd_hda_codec snd_hwdep snd_pcm_oss parport sr_mod cdrom snd_pcm acpi_cpufreq mperf r8169 mii drm snd_page_alloc shpchp asus_atk0110 wmi button sg snd_seq snd_timer snd_seq_device snd_mixer_oss snd soundcore dm_mod autofs4 btrfs raid6_pq zlib_deflate xor libcrc32c ohci_pci xhci_hcd processor thermal_sys scsi_dh_alua scsi_dh_rdac scsi_dh_hp_sw scsi_dh_emc scsi_dh ata_generic pata_
atiixp [last unloaded: vmnet]                           
2014-10-10T00:18:46.711228+02:00 andromeda kernel:  1249.514547] CPU: 2 PID: 52 Comm: khubd Tainted: P         C O 3.11.10-21-desktop #1                                          
2014-10-10T00:18:46.711231+02:00 andromeda kernel:  1249.514553] Hardware name: System manufacturer System Product Name/M4A77TD, BIOS 2104    06/28/2010
2014-10-10T00:18:46.711234+02:00 andromeda kernel:  1249.514558] task: ffff88022c89c640 ti: ffff88022c89e000 task.ti: ffff88022c89e000
2014-10-10T00:18:46.711237+02:00 andromeda kernel:  1249.514563] RIP: 0010:<ffffffffa144a23f>]  <ffffffffa144a23f>] r871xu_dev_remove+0x2f/0x110 [r8712u]
2014-10-10T00:18:46.711240+02:00 andromeda kernel:  1249.514581] RSP: 0018:ffff88022c89fc30  EFLAGS: 00010292
2014-10-10T00:18:46.711242+02:00 andromeda kernel:  1249.514586] RAX: 0000000000000000 RBX: 0000000000000000 RCX: 000000000000de0b
2014-10-10T00:18:46.711245+02:00 andromeda kernel:  1249.514590] RDX: 000000000000de0b RSI: 0000000000000000 RDI: ffff8801e9347030
2014-10-10T00:18:46.711248+02:00 andromeda kernel:  1249.514594] RBP: ffff8801e9347030 R08: 0000000000000000 R09: 0000000000000000
2014-10-10T00:18:46.711250+02:00 andromeda kernel:  1249.514598] R10: ffff88004eea8290 R11: 0000000000000002 R12: 0000000000000800
2014-10-10T00:18:46.711252+02:00 andromeda kernel:  1249.514602] R13: ffff880226eef888 R14: ffff880226eef888 R15: 0000000000000000
2014-10-10T00:18:46.711255+02:00 andromeda kernel:  1249.514608] FS:  00007f36d52ad700(0000) GS:ffff880237c80000(0000) knlGS:00000000f7549940
2014-10-10T00:18:46.711258+02:00 andromeda kernel:  1249.514613] CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
2014-10-10T00:18:46.711260+02:00 andromeda kernel:  1249.514617] CR2: 0000000000003ee8 CR3: 00000001dde3d000 CR4: 00000000000007e0
2014-10-10T00:18:46.711263+02:00 andromeda kernel:  1249.514621] Stack:
2014-10-10T00:18:46.711266+02:00 andromeda kernel:  1249.514624]  ffff8801e9347030 ffff8801e9347000 ffffffffa145a628 ffff880226eef800
2014-10-10T00:18:46.711268+02:00 andromeda kernel:  1249.514633]  ffff880226eef888 ffffffff8141848b 00000000e93470d8 ffff8801e9347030
2014-10-10T00:18:46.711270+02:00 andromeda kernel:  1249.514641]  ffffffffa145a628 ffffffff81c802a0 ffff880226eef888 0000000000000000
2014-10-10T00:18:46.711273+02:00 andromeda kernel:  1249.514649] Call Trace:
2014-10-10T00:18:46.711277+02:00 andromeda kernel:  1249.514761]  <ffffffff8141848b>] usb_unbind_interface+0x5b/0x1c0
2014-10-10T00:18:46.711322+02:00 andromeda kernel:  1249.514776]  <ffffffff813b9415>] __device_release_driver+0x75/0xf0
2014-10-10T00:18:46.711339+02:00 andromeda kernel:  1249.514788]  <ffffffff813b94a9>] device_release_driver+0x19/0x30
2014-10-10T00:18:46.711342+02:00 andromeda kernel:  1249.514797]  <ffffffff813b8cb8>] bus_remove_device+0xe8/0x170
2014-10-10T00:18:46.711345+02:00 andromeda kernel:  1249.514808]  <ffffffff813b59c2>] device_del+0x122/0x1c0
2014-10-10T00:18:46.711348+02:00 andromeda kernel:  1249.514821]  <ffffffff81416080>] usb_disable_device+0xa0/0x260
2014-10-10T00:18:46.711351+02:00 andromeda kernel:  1249.514832]  <ffffffff8140caab>] usb_disconnect+0x9b/0x1b0
2014-10-10T00:18:46.711353+02:00 andromeda kernel:  1249.514844]  <ffffffff8140e288>] hub_port_connect_change+0xc8/0xae0
2014-10-10T00:18:46.711355+02:00 andromeda kernel:  1249.514855]  <ffffffff8140efa0>] hub_events+0x300/0x9b0
2014-10-10T00:18:46.711358+02:00 andromeda kernel:  1249.514869]  <ffffffff8140f675>] hub_thread+0x25/0x160
2014-10-10T00:18:46.711361+02:00 andromeda kernel:  1249.514881]  <ffffffff81071c4f>] kthread+0xaf/0xc0
2014-10-10T00:18:46.711363+02:00 andromeda kernel:  1249.514894]  <ffffffff815adf3c>] ret_from_fork+0x7c/0xb0
2014-10-10T00:18:46.711366+02:00 andromeda kernel:  1249.514903] Code: 49 89 fd 41 54 55 48 8d 6f 30 53 48 89 ef e8 b9 ee f6 df 31 f6 48 89 c3 48 89 ef 4d 8b 6d 30 4c 8d a0 00 08 00 00 e8 21 f1 f6 df <80> bb e8 3e 00 00 00 4d 8d b5 78 ff ff ff 0f 85 9d 00 00 00 48 
2014-10-10T00:18:46.711369+02:00 andromeda kernel:  1249.514970] RIP  <ffffffffa144a23f>] r871xu_dev_remove+0x2f/0x110 [r8712u]
2014-10-10T00:18:46.711372+02:00 andromeda kernel:  1249.514986]  RSP <ffff88022c89fc30>
2014-10-10T00:18:46.711374+02:00 andromeda kernel:  1249.514989] CR2: 0000000000003ee8
2014-10-10T00:18:46.711377+02:00 andromeda kernel:  1249.515056] --- end trace eaae39af03422100 ]---

Then usb stop recognicing new devices: usb sticks plugged in in a usb switch. Then I thought it was something with the hub, so I unplugged it, then I had tons of errors like these:


2014-10-10T00:24:38.318129+02:00 andromeda kernel:  1601.591065] usb 1-1.4: clear tt 1 (9072) error -71
2014-10-10T00:24:38.336154+02:00 andromeda kernel:  1601.609110] usb 1-1.4: clear tt 1 (9072) error -71
2014-10-10T00:24:38.354060+02:00 andromeda kernel:  1601.627012] usb 1-1.4: clear tt 1 (9072) error -71

And usb stop working at all.

I tried to restart it in different ways:


andromeda:~ # /etc/init.d/boot.udev restart
redirecting to systemctl restart udev.service
andromeda:~ # 

But it did not seem to do anything

Then I tried


andromeda:~ # rchal restart
If 'rchal' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf rchal
andromeda:~ # 

Which is the right way to reset the usb system?

regards

I had something similar happen a few years ago. I have a USB gizmo for reading an SD card. I plugged in the gizmo without first inserting the SD card, and it messed up my USB system. A cold boot (after power-off) was the only thing that fixed it.

On 2014-10-10 00:46, fperal wrote:


>   2014-10-10T00:18:34.602998+02:00 andromeda kernel:  1237.390290] usb 2-3: r8712u: Firmware request failed
>   2014-10-10T00:18:46.711148+02:00 andromeda kernel:  1249.514156] usb 2-3: USB disconnect, device number 2
>   2014-10-10T00:18:46.711191+02:00 andromeda kernel:  1249.514372] BUG: unable to handle kernel paging request at 0000000000003ee8

Here I would consider if a reboot is in order.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

Thats what I did (in fact twice, because I reproduced it twice) but I was wondering if there was something more to do

On 2014-10-10 16:26, fperal wrote:
>
> Thats what I did (in fact twice, because I reproduced it twice) but I
> was wondering if there was something more to do

A bugzilla… but your kernel is tainted.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)