Reset Firewall

Browsed through settings on firewall. Looked into options, wrote config files, etc. Everything still working. Rebooted and nothing works.

  1. Browser can’t find servers.
  2. KDE Update widget can’t find server.
  3. No access to Package Repositories.

OK, I broke the firewall.

I’m using the LiveCD to access the internet on the same machine.

Using SuSE 11.2 x64.

Already tried copying /etc/sysconfig/SuSEfirewall2 config file and directories from LiveCD back to the installed directory.
I delete the original files before pasting the copies.
Seems to revert back to the original file.



in YaST, go Security > Firewall, and turn off the firewall

then, go Software > Software management, search on firewall and update all

then, go Security > Firewall, hold your breath, turn the firewall back
on, and hope

if that fails, try:

boot from install media andon first page (see select “Repair Installed System”

if that fails, boot again from install media and progress the step
“Installation Mode” (like on the graphic following paragraph 4 in the
same link) and try to select that “Repair Installed System” (i think
they are different)

it that fails, you might have to reinstall…unless someone else has a
bright idea of how to repair what you broke, without you being able to


The configuration of the firewall (to make the iptables) is in /etc/sysconfig/SuSEfirewall2. To make a fresh start I wouuld try to
. remove the SuSEfirewall2 package;
. check if /etc/sysconfig/SuSEfirewall2 is still ther, when yes delete it (maybe yoy want to save it first);
. install SuSEfirewall2 anew.

hcvv wrote:
> /etc/sysconfig/SuSEfirewall2.

thanks! i didn’t know those details…and, i think they are crucial to
the map i gave…


Couldn’t get it to work. I think defaults between the original setup and the file created may be different. Had to re-install linux on another HD.

Maybe other locations for settings. Tried to search for files the same size, etc. but had to give up and try a fresh install. All OK.