rescue killed my systems

Hello listers,

A few weeks ago I installed OpenSuse 11.2 on my backup PC. Still configuring my backup PC my daily PC crashed. (Yes, Murphy was here all week long.) So I also installed 11.2 on my daily PC.

Before reinstalling my PC I saved what was left of my data to my backup PC using the rescue system from DVD. (attach disks to the backup PC, mount LVM’s and cp -a the files)

Next I installed 11.2 on my daily PC (new partitions etc). The install on my daily PC went very well. It was reconfigured and worked perfectly. And then I restored the LVM data again using the rescue option. Both save and restore were done on the backup PC.

Now it gets weird. After the copy of files my backup PC is not able to boot from HD. I still can boot from DVD and select boot from harddisk. So while a bit annoying I can boot my backup PC.

But after the copy (like I said, through the rescue on the backup PC) the daily PC is not able to boot. I now can’t boot from HD but also not through the DVD. Repair did repair some faults but in the end it didn’t resolved the problem, I still can’t boot. Reinstall installed the system on /dev/sda1 but once again I can’t boot from HD or DVD.

How can I get my PC, or rather both, get to boot from HD again? Note that even an install on the daily PC didn’t solve the problem.

And even more, I would expect rescue to be safe but instead I end up with two PC’s in error. Any ideas as to why this has happend?

Regards, Berry.

One PC at a time. The restore wouldn’t have anything to do with the main PC failing to boot now, since you have done a fresh install.

What errors are you getting when the install finishes and you try to boot? What is your disk configuration? Have you set it to boot from HD in the BIOS after the install?

I might help to see the disk layout

in a console

su -
your root password
fdisk -l

Also let use see the menu.lst file
also as root
cat /boot/grub/menu.lst

Thanks four your replies. Yes I agree, one PC at the time.

My daily PC is fixed. As it turns out the disks were connected to the wrong sata ports. The disks I used were my (former) lvm disks. These were connected to the ports that supposed to hold a raid set. After the copy of the lvm I connected them back on the same ports. While the bios can still access the disks and the installer installs linux on there (even as sda and sdb) the bios can’t boot from there. And the DVD tries to boot on these disks with no success, probably for the same reason. So connecting them to the lower sata ports should fix that. But actually I got myself a new disk and started over from scratch.

That leaves the backup PC. I’ll have to look into that. Maybe I’ll have to reinstall this PC too. But my priority now is to get my old data back (if possible, sigh).

Thanks, Berry.

Yes, usually the BIOS can only boot from a couple of slots, generally the first two. The bootstrap from the DVD also relies on the BIOS to load the OS, so it is under the same restrictions.

Indeed, as I already found the daily PC can’t boot from all sata connections.

As it turned out by backup PC mainboard is smarter then me. When I ran rescue for the copy of LVM I obviously had to attach the harddisks. This had an unexpected result, the BIOS reordered the disks it detected. When I disconnected the disks the BIOS didn’t reorder them back correctly. The LVM volumes were now configured as primary devices. The BIOS now tried to boot from a disk without boot partion, the boot from CD works slightly different and was still able to find the correct disk and started booting from there on.

To solve this I disconnected all disks, connected only the boot disk and then rebooted through BIOS setup. The BIOS now enabled the bootdisk as primary device. Next I connected the remaining disks and went through BIOS setup again. Now the disks are in the correct order and I can boot normally again.

Thanks for your help.