Rescue disk and repair MBR

I was trying to compile, install and uninstalling QT. I think something got broken because when I rebooted my system it complained about “could not find D-bus”.

I tried using yast (text mode) in rescue screen to re-install dbus.

After that the grub load screen came up. “GNU GRUB Version 2.00 Minimal BASH-like editing is

I found some instruction on how to repair the grub for OpenSUSE using the rescue CD.

However when I run:

 grub> find /boot/grub/stage2

 Error 15: File not found

How do I use the rescue CD to fix this issue and restore the normal booting in my system?

Thank you,


If you have grub2 installed, the commands you are running are irrelevant as they are legacy grub commands. Do you know whether / has been mounted?

I have the OpenSUSE 12.2 CD. I boot and go into rescue mode.
I don’t think / has been mounted.
I can mount /dev/sda5 /mmt and see all the files in the system.
What can I do to fix this?
Thank you,

Try caf4926’s how-to on reinstalling Grub2:

I’ve used it with success myself.