Repository Parse error

I added the repository for Mono with YaST:

I clicked on YaST Software Management. YaST appears busy for awhile, and then comes up with an error:

There was an error in the repository initialization.
'Mono': Parse error

Can this be fixed? If so, how?

In the end I would like to install monodevelop. I did go to:,
and clicked on the one-click, but had some errors like no installable providers of…, so I’m stepping back and just installing the repository, which is when I got the above error.

Any thoughts?

Thank you.

I’m getting the same error. I also get an error that Gtk# is not available when a project is built. Could this be an x86_64 problem? I have a lot of those :frowning:

I had the same problems. Then:

I installed yum - added the repository to /etc/yum.repos.d/<file> and it worked fine.

The RPM database in the directory /var/lib/rpm might be damaged.
rpm can rebuild that database (as su)

  1. Please make a backup of the directory /var/lib/rpm first.
  2. Execute the command** rpm --rebuilddb**

You can also try zypper in mono* which will give you all the mono packages



I am using openSUSE 11.2, and I have got the same problem but not related with ‘mono’. I have rebuild the db but it is not fix yet, still same message. Do you have any other suggestion?

Best regards,