Repository for Video Codecs


in August I installed Tumbleweed and finally got everything working. Everything? Not quite: as usual after installing a new Linux, Videos don’t play. So far, I got around without, but now I’m really missing it. So, I spent an evening searching around, but still couldn’t find out the correct repository name.

From my last installations I know that for some copyright reason the corresponding repository isn’t installed automatically. After some reading I found out (and remembered) it is called “packman”.

After some more reading, I learned about a new layout of the packman repository(in four parts instead of one) and I got a list of mirrors at

Also, thanks to this forum, I found the list of packages at opensuse:

However, my quite straightforward question wasn’t answered in either of these places:
What is the correct URL of the packman repository to enter in YAST (for Tumbleweed)?

Instead, I have one more question now: Do I need to add four repositories (and what are their names) for simply playing video files in VLC and Kaffeine?

Thanks for your answers and for all the answers you gave in the past which helped me a lot!



PS: as a side question: Why isn’t there a button in Yast where I can browse for the more common repositories by category, e.g. Multimedia/video/codecs instead of searching for URL’s in the net?

Either the top one for all four, or as individual adding Essential etc…

From the command line use the following for all of them;

zypper ar -f -g -n packman packman

Since it’s a third party repo and beyond the scope of the ‘open’ in openSUSE and avoiding any potential litigation for patent encumbered things.

Thank you!
That worked.
VLC does still not understand any Codec but with kaffeine I can now play at least some codecs (.mpeg., .dat, some .vob). So VLC and all the other Codecs is a question for another thread.

you need to do a full vendor change to the packman repo and the install vlc-codecs package (which does not exist in OSS) try

zypper dup --from packman
zypper in vlc-codecs

that should fix vlc

That fixed it, really!

Thank you very much indeed.