Repository access problem OpenSuse 10.3

Dear all,

Since a few days (actually almost 2 weeks) I am having trouble to update my distribution. I always get the error “Couldn"t connect to host”

Here an example when trying to update the OSS repository
Unable to create repository from URL ‘http://download.opensuse.org/distribution/10.3/repo/oss/suse
Error trying to read from http://download.opensuse.org/distribution/10.3/repo/oss/suse
History:

However using my browser it is no problem at all to access the repository. Neither it is a problem for a mirror site. Any idea what could be broken here?

Thanks for your help.

Have you tried deleting them. The replacing them?

have you an proxy or go you direct to the net?
block your firewall?
can you run :
curl http://download.opensuse.org/distribution/10.3/repo/oss/suse/repodata/repomd.xml

or
wget http://download.opensuse.org/distribution/10.3/repo/oss/suse/repodata/repomd.xml
?

Thanks for your response. I had tried everything - thought about the proxy and FW as well. Yet it was looks like a corrupted entry in the var/lib/zypp/db/patches directory. After renaming the directory (recommendation found through google-ing) and recreating the directory (well and a reboot) everything works now again like a charm.

Thanks again to all responding to my posting.

Cheers :slight_smile:

I’m having this exact same problem, could you post how you fixed it.

What file became corrupted and which directory did you replace / rename ?

Thanks,

Stuart