repositories adding Mozilla

Hi All,

I am having trouble adding community repositories. I am using Open Suse 11.0.

Open YaST->Software Repositories->Add->check radio button on Community Repositories->click on next

on 33% I get this error “Unable to download the list of repositories or no repositories defined” How do I fix this issue? I would like to add different community repositories but it keep error at 33 percent.

The long story:
I installed 11.0 setup the community in the setup process. I have selected the Mozilla community repositories. I had trouble with Firefox upgrading. I want to update to the current version. I go to YaST to update and keep seeing ver 3013 instead of 3.5.2. I deceided to delete Mozilla community repositories to re-add it so I can update to 3.5.3.

Work around:
I download Firefox from their site. I extract it and using the current ver 3.5.3. but it is not using actual Suse Firefox software. I go to the Suse version software and it is running I want YaST to install Firefox not use the folder Firefox.

Try a mirror that has repositories on it rath than the redirector.
eg this one has 3.5.2

It may also be due to the power outage at the moment, see the
announcement at the beginning of the forum.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 3 days 19:57, 2 users, load average: 0.12, 0.17, 0.35
GPU GeForce 8600 GTS Silent - Driver Version: 190.18

Thanks for the quick reply did not know about power outage.

I tried to add the url to my Yast and could not add as http. I then deceided to just go to the domain Index of /pub/opensuse/repositories/mozilla/openSUSE_11.0. I only saw V3.5.2 MozillaFirefox-3.5.2-2.1.i586.rpm guess it is the stable version which V3.5.3 just came out.

Another problem after download the RPM file. I tried to install it with YaST. I get this warning box in the middle. “nothing provides MozillaFirefox-branding=3.5 needed by MozillaFirefox-3.5.2-2.1.i586”

Conflict Resolution:
do not install MozillaFirefox-3.5.2-2.1.i586

Now what seems to be the problem?

Try adding the repository from the command line (all one line in
case of wordwrap) then;

sudo zypper ar

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 3 days 20:46, 2 users, load average: 0.08, 0.55, 0.62
GPU GeForce 8600 GTS Silent - Driver Version: 190.18

THANKS malcolmlewis (Mate)

I just do not know enough command line stuff. It put it in the Yast and I was able to update Firefox to 3.5.3.

Now I will not have it crash with closing broswer.

side note - hv 2 get mi mate in Wales to Linux LOL

Thanks again