Repositiory directory problem.

Okay. So here is the issue.

I installed 11.4 from dvd located on a usb. When I open yast and it attempts to update my repos it states the following:

Cannot access installation media
hd:///?device=/dev/sdb1
(Medium 1).
Check whether the server is accessible.

In the details:

Empty destination in URI: hd:///?device=/dev/sdb

SDB1 is my USB - which is no longer plugged in. I know this can be fixed by $ edit /boot/grub/device.map

(hd1) /dev/disk/by-id/usb-Best_Buy_Geek_Squad_143492192C431BDB-0:0
(hd0) /dev/disk/by-id/ata-ST9100821AS_5NJ0RNJH
~

I am rather fearful of poking around in there because after trying once before I caused a catastrophic system’s failure which required a total reinstall. =/

Disk /dev/sda: 100.0 GB, 100030242816 bytes
255 heads, 63 sectors/track, 12161 cylinders, total 195371568 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xed1f86f7

Device Boot Start End Blocks Id System
/dev/sda1 63 117028799 58514368+ 7 HPFS/NTFS/exFAT
/dev/sda2 * 117028861 195371007 39171073+ f W95 Ext’d (LBA)
/dev/sda5 117028863 158722919 20847028+ 82 Linux swap / Solaris
/dev/sda6 158724096 173389823 7332864 83 Linux
/dev/sda7 173391872 195350527 10979328 83 Linux

I clearly want my repos on SDA6, I just have no clue how to fix this. I checked google and a number of other places before I came here.

Disregard. I fixed it.

I went into the yast repos and found the SDB1 and disabled it. Then it defaulted to sda6.

After installation, the install media is usualy disabled by the install process because, with a running system, you only need the network repos (OSS, non-OSS and Update). When the install didn’t do it, disable them yourself (YaST > Software > Software repositories). You do not need the media anymore because everything is now on-line in it’s most up-to-date status (important for security).