Repo Site Error Message - Any Suggestions?

I have just started getting a pop up message as follows:-

 Problem connecting to a software origin
File '/repodata/repomd.xml' not found on medium ''

The popup is a pain but worse, I have no idea what has gone wrong. Is it repo server issue or a problem at my end?
Can anybody help please?

Is this exactly the message you get?
I see 2 obvious errors in that URL:

But anyway, that repo has been removed for 12.2.
You should think about upgrading to a newer version (12.3 f.e.), since 12.2 is out of support already since a week.

The following distributions are expected to receive updates until the specified date:
openSUSE 12.2 - Jan 15th 2014 which is in -7 days (2 months after release of 13.1)

You could use this repo instead for now:
But this only contains older versions of the software.

Thanks but not critical now I have to face up to reality!!! I shall upgrade to 13.1 (or 13.2?).

Thanks again,

Well, 13.2 is still far away (the Roadmap says July 2014), so it’s either 12.3 or 13.1.

12.3 should be safer since it is only officially supported to upgrade to the next version.
If you do want to upgrade directly to 13.1, you should use the offline method, though. (via Installation-DVD or NET-Install CD)

There is a problem in the dbus upgrade procedure that could cause an online upgrade via “zypper dup” to hang somewhere in the middle (you should have a fully updated 12.3 system before the upgrade to prevent that).
If you do a fresh install anyway, this doesn’t matter of course.

And please next time use copy/paste to post between CODE tags. We others trust that you do not cheat there by inventing, changing, removing things there (unless you explicetly tell so, e.g. when you ** out a password).

Hi Henk,

I accept the slap on the wrist but I have been a visitor here long enough to know what is required. I did try to get it right but couldn’t copy and paste as previously advised and trackball is playing up. In the same way as one can make spelling errors I guess!

Hi Wolfi323,
Well I have finally found time to try to upgrade. I wonder if you have a few moments to give me some further advice please as I ahve run into problem:-

In order to start with a “clean” machine I rebooted before doing anything else. Oddly, grub reported openSUSE 12.1 installed. I guess I did something wrong last time but checking with

cat /etc/*-release

confirms openSUSE 12.2 so, taking your advice I tried a Network install of 12.3. For reasons I do not yet understand this stalls. I get the screen asking if I want to boot from hard drive, install, check media etc and if I select “Installation” I get a few lines of text on the console and then screen goes dark and nothing further. Strange because I always use Network Installation and that is how I installed 12.2 as a fresh install on this machine, not an upgrade.

So my question is can I do a zypper dup to go from 12.2 to 12.3 without risk?


To maximize safety, I recommend upgrading using the DVD (I don’t know what medium you’re using for a “Network Install”).
That way, if something happens to your network connection you’ll still have enough source on your DVD to recover.

On the other hand, if you do a network upgrade (you take your chances, but you d/l only the packages you need to upgrade), then I’d recommend you use the command line zypper method. If you want to consider this option, be sure to follow the official documentation

In general though, whatever method you use to upgrade involves the following steps

  • Update your existing system with the latest available patches.
  • Backup if you value what you have in case this get very bad (shouldn’t, but if a mistake is made you can certainly lose everything)
  • If you’re jumping more than one distro version, you may be advised to add a special repository
  • Disable your repositories pointing to your current distro version and configure new repositories that point to the new distro version
  • Execute the upgrade. It should swap out your old system files for new. Although mentioned by others, I doubt that it makes a diff whether your /home directory is on a special partition or not but of course it’s always safer if partitions are used to separate files that are used differently.

For the inexperienced, d/l the DVD and execute the upgrade from it. You will have an option to connect to online sources if you wish (like a network based upgrade) but I wouldn’t recommend it for the less experienced. It’ll take more time installing old files for the new distro and then replacing those with updated files, but it’ll get you from one step to another with more certainty and less complexity (safer than sorry).


Hello budgie2,

No hard feelings, but as you see, making typos in what others think is a straight copy, leads to misinterpretations and useless discussions. In nobodies favour :wink:
As I suggested: next time better.

BTW, the case of GRUB saying 12.2 and the system in fact being 12.3 (and variations) was here in the forums a few times. IIRC, during an Upgrade (thus not a fresh install), the text in the grub menu is not changed. Confusing.

I guess that this happens whith an update using changed repos and zypper dup. Because IMHO that would only install newer packages and not change configuration fiiles like that of Grub. Flaw or Bug?

No, that happens on any upgrade, even offline using the DVD.
The text is not changed on purpose, because it is a user-editable configuration item. You can change it to your likings in YaST->System->Boot Loader->Boot Loader Options (“Distributor”).
There was some discussion about that after the 13.1 release again, with a proposed patch to fix it, but I don’t know if this will be changed for 13.2 then or not.

You may have to select “No KMS” on the boot screen (F4 it is I think).

So my question is can I do a zypper dup to go from 12.2 to 12.3 without risk?

Well, an upgrade always bears a certain risk, depending on how customized your installation is.
But if you follow the instructions in the link tsu2 gave you, it should work.

That said, my last clean installation on the system I’m sitting at the moment was SuSE 8.1.
Since then I only upgraded. (most of the time with “zypper dup” since it is available)

First my thanks to all those who have bailed me out here. The links were great and just what was needed. I knew I had read something similar but couldn’t find it when needed so many thanks. I have upgraded to 12.3 and will run this for a few days to make sure all is working before moving on to 13.1.

In order to check it was not my hardware I tried the Network Installation CD for 12.2 and it worked fine but subsequent versions give me the blank screen before I get the opportunity to select any booting options like the F3 mentioned above. Will do a bit more and post if I find a solution. Meanwhile I shall use upgrade as noted above.

Finally and for Henk: I think on reflection I mis-posted here and I should have gone to the installation forum. If you consider this thread useful by all means move it if rules allow.

Thanks again.

I reread the whole thread and I can indeed not find any suggestion of this having something to do with Virtualisation. Thus it may indeed be better in Install/Boot/Login.

It will be moved there and is CLOSED for the moment.

Moved from Install/Boot/Login and open again.

Many thanks Henk.