repo error and speed issues?

I get this message every time I open install/remove software…

There was an error in the repository initialization.
‘repo-update’: |] Valid metadata not found at specified URL(s)
History:

  • |] Repository type can’t be determined.

also, the test repos seem to be very slow. is that normal? I have a 35/35 mbit fiber line and most Linux boxes I have download near 4,000kbs but the opensuse test repos are lucky to be running at 150kbs. takes awhile to get certain things.

It would be helpful if you posted the result of

zypper lr -d

and confirm what version of openSUSE you are using, because this is the pre-release section

yes, I realize it is…

louis@linux-2ve8:~> zypper lr -d

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

–±-------------±----------------------±--------±--------±---------±---------±----------------------------------------------------------------±-------
1 | PK_TMP_DIR | PK_TMP_DIR | Yes | Yes | 99 | plaindir | dir:///var/tmp/TmpDir.O88WNG |
2 | repo-debug | openSUSE-11.4-Debug | No | Yes | 99 | NONE | Index of /factory-snapshot/repo/debug |
3 | repo-non-oss | openSUSE-11.4-Non-Oss | Yes | Yes | 99 | yast2 | Index of /factory-snapshot/repo/non-oss |
4 | repo-oss | openSUSE-11.4-Oss | Yes | Yes | 99 | yast2 | Index of /factory-snapshot/repo/oss |
5 | repo-source | openSUSE-11.4-Source | Yes | Yes | 99 | yast2 | Index of /factory-snapshot/repo/source |
6 | repo-update | openSUSE-11.4-Update | Yes | Yes | 99 | NONE | http://download.opensuse.org/update/11.4/ |
louis@linux-2ve8:~>

Both there as su -

zypper rr 6
zypper rr 1

There are no updates for this release. If you want to keep up with the development I can show you what to add

that would be great thanks…
that did the trick

anyway to get video to work in 11.4 as of yet? both banshee and totem fail to play any clips on my drive. they are looking for an On2 VP6/flash etc plugin

You can disable the current repos and just use these two

Index of /factory/repo/non-oss

Index of /factory/repo/oss

Add Packman Factory

zypper ar -f http://packman.jacobs-university.de/suse/factory/ packman
zypper ref

accept key with ‘a’ = always

Try running this

zypper in libavcodec52 libavdevice52 ffmpeg libdvdnav4 libdvdread4 libquicktime0 libxine1 libxine1-codecs libxvidcore4 smplayer vlc w32codec-all xine-ui xvidcore

Not all the packages will be there
Just give it a go

thanks for the help and info. unfortunately I’m still missing the proper codecs. probably in the packages it couldn’t find.

thanks again though

Please try doing this:
http://dl.dropbox.com/u/10573557/Switcher%20Pics/packman%20in%20gnome.png

Are you trying to play something online that you can link me to?

In software management search: gstreamer

add in as per my list

rpm -qa | grep gstreamer
gstreamer-0_10-fluendo-mp3-0.10.14-42.pm.43.7.i586
libgstreamer-0_10-0-0.10.30-999.pm.1000.12.i586
gstreamer-0_10-0.10.30-999.pm.1000.12.i586
gstreamer-0_10-plugin-gnomevfs-0.10.30-999.pm.1001.6.i586
gstreamer-0_10-plugins-good-0.10.25-2.6.i586
gstreamer-0_10-plugins-bad-0.10.20-5.1.i586
PackageKit-gstreamer-plugin-0.6.8-3.2.i586
gstreamer-0_10-ffmpeg-0.10.11-999.pm.1000.9.i586
gstreamer-0_10-plugin-hal-0.10.25-2.6.i586
gstreamer-0_10-plugins-base-0.10.30-999.pm.1001.6.i586
gstreamer-0_10-plugins-ugly-0.10.16-3.4.i586

ok, in the process of switching to packman but lord, some of this stuff is coming at 4k/B/s

will do as soon as this is done. and not trying to play anything online, flash works fine in a browser as does moonlight. it’s .flvs, avis, movs etc I have on my hard drive they wouldn’t play

ok, switching to packman did the trick, I couldn’t see ffmpeg and fluendo before, everything seems to be working…

btw, not sure if you care or not but compiz doesn’t work with VirtualBox as of yet.

Well at least we got somewhere.
I use kde and so not compiz and my install is not in a VM. But that info doesn’t surprise me. And in any case, I would never recommend using Compiz in a VM. OK maybe just to see if it works but not in a working VM.
I guess you would need the 3D settings enabled in VM settings.

Compiz is rather a nightmare in a VM. I spoke too soon before. .flv files play fine, but now, although they finally play, .avis and mp4s and such stutter and stop etc. such is the way of testing.

TBH
I have never really tried multi-media on a VM, not properly anyway. Sure I will have used flash player but not much more.
At one time I did a lot of testing in VM’s but I progressed to the real thing. I seldom use Virtual Box now.

ok, I am updating 11.4 as I type. It said there were 1144 updates lol. I think this is going to be awhile since the repositories feed me packages at a tenth the speed of anything else I run at best. I still don’t get that.

I also started getting this error:
“Download failed: File ‘/repodata/repomd.xml.key’ not found on medium ‘http://packman.jacobs-university.de/suse/factory/’”
and I don’t know how to fix it, they still seem to download however.

Just ignore the Packman error, it’s OK

Factory updates are massive but speed should normally be good.

well, I don’t get it. I actually posted a question over in the network threads. The speed for me anyway is not good. I am on a 50 Mbps connection and the fastest I’ve ever received from the openSUSE repos was about 240 kB/s and as slow as 1.8 kB/s. I gave up waiting for the stuff to download. It should of taken maybe 10 mins or so and of course time to install but it was 2 hrs with another 2 hrs to go.

I’m not sure what’s going on but, I have 20+ other Linux guests and I download from them on avg. @ 3-5 MBs. I could of downloaded 10 Linux .isos and installed them in less time lol. I am going to wait for 11.4M3 on the 5th and go from there.

thanks again.

I have experienced slow download speeds from openSUSE’s update servers also over the last month or so. Not always, but about half the time. I did some updates today for Milestone 2 and the speed was middlin’. Not fast, but not too slow.

I think zsync is now being used because all downloads happened first, followed by the installation of all packages.