Repo Access Denied

So I’m trying to download and setup qemu/kvm on my new install and every time in install any libvirt packages i get an error saying that ‘http://cdn.opensuse.org/tumbleweed/repo/oss/x86_64/libopeniscsiusr0-0.2.0-104.3.x86_64.rpm’ access is denied. I checked the link and I’m getting a 403 error, but http://cdn.opensuse.org/tumbleweed/repo/oss/x86_64 is up and working, its just the libopensource repo. Not sure if there are mirror issues happening on SUSE’s end, or if its just a broken mirror

Problems with repos are usually transient, which means if you wait a while before trying again, usually they will work as expected. I’ve had a lot of trouble with repo URLs using cdn. I find replacing cdn with download in the URLs in the repo files in /etc/zypp/repos.d/ generally provides more reliable results. Both cdn and download are redirectors. You have the option to replace the default URL with one (or several) from a specific mirror. I sometimes use ftp5.gwdg.de (in Europe), even though I am in USA.

The cdn. Repos are installed with an rpm as a service.

So delete the rpm and add the Repo by hand.

Here on Leap I have locked and not installed:

zypper ll

# | Name                       | Type    | Repository | Comment
--+----------------------------+---------+------------+--------
1 | openSUSE-repos-Leap        | package | (beliebig) | 
2 | openSUSE-repos-Leap-NVIDIA | package | (beliebig) | 

I’m not even sure where the cdn is coming from since all my mirrors are using download subdomains and not cdn subdomains, this is the output of “zypper lr -d” if it helps

# | Alias                            | Name                                   | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                      | Service
--+----------------------------------+----------------------------------------+---------+-----------+---------+----------+--------+----------------------------------------------------------+--------
2 | download.opensuse.org-non-oss    | Main Repository (NON-OSS)              | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/    | 
5 | download.opensuse.org-oss_2      | Main Repository (OSS)                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/        | 

In my /etc/zypp/repos.d/ folder it is all also labeled as a download subdomain and not the cdn subdomain

I did try to add the same repo but with cdn as the subdomain and still got the same error of
“Permission to access ‘’ denied.”

I cant post all my repo information because I can only put 2 links in a comment as a new user

update: i tried adding the Index of /pub/opensuse/tumbleweed/repo/oss/ repo then tried again and got the same error but for the gwdg domain, so it might be an issue with the firewall/proxy at my work? ill try again when I’m home, and again in the morning if it isn’t just the firewall

Final update: it was either resolved with time or it was due to the firewall/proxy, but I was able to install without an error on my home network

sorry for the spam posting, but i cant edit my replies

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.