Reply to email puts cursor in the wrong place

Hi all, FYI, I’ve put this in the KDE forum also, with not much response.

When I start a reply or a reply to all email, the template that is used keeps on putting the cursor after the signature, when I want it to put it at the beginning of the email. I am using the default template.

%REM=“Default reply template”
On %ODATE %OTIMELONG you wrote:

I have done a google search on this and it is supposedly fixed, although I could not find out in which version. Any help?

I am running KDE 4.3.5, KMail v1.12.4.

I have the same Kmail as you and the reply template has:


Op %ODATE %OTIMELONG schreef u:

Which, apart from the %REM (and the language used) is the same as you have. And it works correct. Maybe try to do away with the %REM.

Thanks, I tried that and it did not work.

Hm, you are aware that there are two of these Answer templates? One for Answer and one for Answer all. Did you check both?

As I (and I suppose most, because nobody complaint until now) do not have the problem, I just try to suggest some things you might have checked allready 10 times, but one never knows.

I have checked both the reply and reply to all templates and made sure that the profiles I am using are using the standard templates not any custom items.

Oops, I run out of ammunition then.

My last try then would be to empty the field thouroughly and type it anew to be sure that no unseen white space or other strange characters are included. But that is more against knowing better.

I can also add that this configurtion is in your home directory in ${HOME}/.kde4/share/config/kmailrc in the part* [GlobalTemplates]*. Here is mine:

----------  Doorgestuurd bericht  ----------

Datum: %ODATE



Op %ODATE %OTIMELONG schreef u:




Ok, I checked out the kmailrc file and it matched what I had in the settings. I played around with different versions of the templates including yours and the problem remained. It seems to happen when the signature is automatically inserted.

In the end I created a custom template in my profile and manually added my signature. This did the trick.

Thanks for taking your time on this, I have a fix albeit a work around.

Nice you can work with it, but it is still unsatisfying we can’t explain where the error is.

True, but in the absence of any other suggestions and help from other forum users, that is the way I have to go (not that I don’t appreciate your help).

I did try KDE 4.4 but I saw a lot of app freezes and crashes so it put me off. I haven’t tried 4.4.2 yet, not sure I want to go down that path just yet. Perhaps I’ll wait for the next 4.4 bugfix release or the next openSuse release and try again.

As I said in an earlier post, when I Googled this problem, there was supposed to be a fix for this specific issue, but I can’t find the KDE/KMail version number or links now.