replace video card on a 12.2 system?

due to the stability issues i’m having with an nvidia fx1800, i would like to replace it with an ati hd3470 and see if anything changes. does there exist a document that details the steps i need to take to bring the system back up with a different video card?

Uninstall nvidia driver and then disable the repo
shutdown
swap GPU
reboot

i’m currently running the nouveau default driver should that make any difference. does the system need to be running in recovery mode when removing the driver?

Then you need remove nothing
Just turn off replace card - boot up again

that was my first thought, but it didn’t work. once X started, both monitors went into invalid video mode. recovery mode does produce single-monitor video. the required ati modules may not be installed. but i’ve not used an ati card since like the days of slackware 7, so i don’t know what should be installed.

Ah…
Try booting to level 3 : https://forums.opensuse.org/blogs/jdmcdaniel3/how-start-opensuse-12-2-grub-2-into-run-level-3-112/

Start yast

Or will it boot in failsafe?

can get into level 3, the radeon kernel mods are loaded. xf86-video-ati package is installed. the recovery/failsafe start works too.

normal start still causes monitors to go into invalid video mode once X starts.

Start up in failsafe mode. I think you’re going to need to edit the grub configuration to remove an offending framebuffer mode perhaps. Are you using grub or grub2?

Are you aware of this
https://forums.opensuse.org/content/115-ati-driver-atiupgrade-new-version.html

grub2. first time for me to use it.

in looking at /boot/grub2/grub.cfg, normal mode sets video=1280x1024. ok for my monitors.
but, recovery mode uses nomodeset and x11failsafe. is this maybe an X config that needs to be rewritten?

The grub2 menu items are based on /boot/grub2/grub.cfg. Let’s have a look at /etc/default/grub (which contains some user settings) first.

openSUSE 12.2: Chapter 10. The Boot Loader GRUB2

grub2 config needs tweaking…may be ok for monitors, but also needs to be okay for graphics card…

Let’s have a look at /etc/default/grub (which contains some user settings) first.

In essence, you may need to experiment with the ‘GRUB_GFXMODE=’ entry eg

GRUB_GFXMODE=auto
GRUB_GFXMODE=1024x768

till you find something that works. When you’ve made the edit you run

grub2-mkconfig -o /boot/grub2/grub.cfg

then reboot…

the hp spec sheet on the hd3470 shows to support 1280x1024 with a max refresh rate of 60hz on a digital connection. the 3470 only has two displayports, one has dp-to-vga adaper (hp supplied, connects to a kvm) the other is dp-to-dvi-d direct to the monitor. these adapters are used on the fx1800; both monitors are showing 60hz refresh. maybe the ati is trying to use the wrong rate?

Maybe the video timing is not quite right. Anyway, try setting a more conservative VESA display mode to start with and see whether that makes a difference.

I’d still like to see /etc/default/grub…

tried every setting down to 800x600, no luck. i have left gfxmode=1280x1024 instead of the default of auto.

two things come to mind, i’m not absolutely sure i have all the required opensuse distribution packages for ati. i’m not sure of this card. it was handed to me and i know it was never used under linux.


# Modified by YaST2. Last modification on Mon Jan  7 21:38:08 CST 2013
# THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
# For the new kernel it try to figure out old parameters. In case we are not able to recognize it (e.g. change of flavor or strange install order ) it it use as fallback installation parameters from /etc/sysconfig/bootloader

# If you change this file, run 'grub2-mkconfig -o /boot/grub2/grub.cfg' afterwards to update
# /boot/grub2/grub.cfg.
GRUB_DISTRIBUTOR=openSUSE
GRUB_DEFAULT=saved
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=8
GRUB_CMDLINE_LINUX_DEFAULT=" video=1280x1024 resume=/dev/sda2 splash=silent quiet psmouse.proto=imps psmouse.resetafter=1 showopts"
# kernel command line options for failsafe mode
GRUB_CMDLINE_LINUX_RECOVERY="showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe"
GRUB_CMDLINE_LINUX=""
# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM=0x01234567,0xfefefefe,0x89abcdef,0xefefefef
# Uncomment to disable graphical terminal (grub-pc only)
GRUB_TERMINAL=gfxterm
# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=1280x1024
# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true
# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY=true
# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
GRUB_THEME=/boot/grub2/themes/openSUSE/theme.txt
GRUB_BACKGROUND=/boot/grub2/themes/openSUSE/background.png

I note that you have ‘video=1280x1024’ in your config file

GRUB_CMDLINE_LINUX_DEFAULT="video=1280x1024 resume=/dev/sda2 splash=silent quiet psmouse.proto=imps psmouse.resetafter=1 showopts"

That could be the cause of your problem.

Try removing that entry so that it looks like

GRUB_CMDLINE_LINUX_DEFAULT="resume=/dev/sda2 splash=silent quiet psmouse.proto=imps psmouse.resetafter=1 showopts"

and use

GRUB_GFXMODE=auto

Then run

grub2-mkconfig -o /boot/grub2/grub.cfg

and reboot. Report back.

i’m not absolutely sure i have all the required opensuse distribution packages for ati.

Your issue is a framebuffer one, not with Xorg-related packages, as the X-server hasn’t even started at this time.

i did. what that seems to do is change the resolution of the screen while the boot messages scroll by (after you hit esc when the splash screen pops up.) it also affects the resolution when you boot into run level 3.
it’s when the logon screen is to be displayed that the video becomes invalid.