Repeated Updates from Packman libav

Hi, I seemed to be getting repeated updates of several libraries from packman. These libraries were dependencies for mplayer. I have temporarily solved the problem by removing the packman repo. Has anyone else seen this problem? Maybe there is something wrong with my system.

Very hard to tell without more specific details. Apper reports may updates but I suspect most are non essential or limited impact at worst. They can wait for housekeeping day. When I see a patch listed I run zypper patch. So far so good … and grateful thanks to all our diligent software maintainers. I’m no expert but I suspect it is best to NOT disable an essential repo like packman.

I was getting repeated attempts to connect to the repository, but the Austrian mirror was down and had been since the day before yesterday. I simply redirected to a different mirror,
Problem solved, at least until this one starts acting up from the new traffic this post creates.

You don’t have to remove it. Just mark it as disabled (uncheck the “enabled” box in Yast Software Repositories).

Yesterday (and perhaps still today), “” was down, causing problems for some folk. I just switched to a different packman mirror.

I’m not sure if that is the problem you are concerned with. Or maybe you just don’t like that packman updates so often.

My solution to the “updates too often” was to turn off Apper (in “Startup and Shutdown”) and turn of the update applet in system tray settings. Then I would use “zypper up” at the command line at my convenience (maybe once or twice a week). That’s in the past tense, because I now run Leap 42.1, so the update applet isn’t Apper. But I still follow a similar practice. I normally reboot twice a week – reboot to Windows to update anti-virus. So I run opensuse updates just before reboot. I usually start updates with Yast online update, because that way I can read the documentation on the reason for those updates. And I follow that with “zypper up”.

I don’t think these were genuine updates. They download and install OK, but then they come up again the next day, or a few days later. I find it hard to believe these libraries need updating so frequently.

I checked in yast2 on the versions and change log, I could not see a reason for the updates.

I put it back. Here they are, they’ve come up again:

libavcodec56 libavformat56 libavutil54 libpostproc53 libswresample1
libswscale3 typelib-1_0-Gst-1_0 typelib-1_0-GstAudio-1_0 typelib-1_0-GstPbutils-1_0 typelib-1_0-GstTag-1_0

My understanding is that they are often a recompile of the same code. This gives a new minor version number, which is why you see an update. When a library changes, everything in that library is recompiled, probably due to dependencies in the “Makefile”. But if this is a dymanic library, only the library needs updating.

For the main opensuse repos, these changes occur in OBS (open build system), and then somebody decides which changed files need to put into a patch. With Packman, we are just given everything that was recompiled.

I’ll repeat an earlier suggestion, though in a modified form. Turn off the update applet (Apper and the tray update applet for 13.2). Periodically run Yast online updates. If there are updates, then follow that with “zypper up”. The “zypper up” will update Packman packages. Doing it only when something is updated at opensuse (via Yast online updates) is probably often enough.

If you prefer to do it with timing, then check for updates once or twice per week. Hmm, Microsoft usually updates once per month, so once per week should be plenty enough unless you are expecting an update and in a hurry to install it.

In plasma right-click the software update applet, select Software Updates Settings…
check weekly

Personally, I do not care if Apper shows me that balloon with the oft-updates when I am logging in. I just ignore it, and the update icon then just sits quietly in the tray/panel.

I do my updates once a week, first the openSUSE required and recommended patches, then the Apper updates.

Since I am using the ESR version of Firefox, direct from Firefox, I also check and update that as necessary.

So, Apper says “Hi” each time I log in. No big deal.:wink:

I see that explains it. I will work something out. I used to use zypper but kept forgetting to run it…

I have that problem, too.

For example, today I rebooted (to briefly run a different system). I forgot to do updates first. So, after login, I then remembered to update. Fortunately it was a minor update so I didn’t need another reboot. I did logout then login again. Tray icons look better after that update.