Repeated Errors During openSUSE 11.0 Installation

I’m installing openSUSE 11.0 from the DVD, and I keep getting the same error pop up as each package is installed:

Subprocess failed. Error: RPM failed: warning: /var/cache/zypp/packages/openSUSE-DVD 11.0/suse/i586/package.rpm: Header V3 DSA signature: NOKEY, key ID 9c800aca

rpmdb: /mnt/var/lib/rpm/Filemd5s: file size not a multiple of the pagesize

error: cannot open Filemd5s index using db3 - Invalid argument (22)

rpmdb: /var/lib/rpm/Filemd5s: file size not a multiple of the pagesize

error: %postun(xorg-x11-libXau-7.3-43.1-i586) scriptlet failed, exit status 255

That same error is presented for each package in the actual installation process, asking me to Abort, Retry or Ignore.

Clicking Retry just brings the same error up again, and Ignore brings the same error up for the next package, presumably not installing the last one. Of course, if the installation does ever finish (after clicking Ignore for all packages) I will no doubt be left with a crippled and unusable installation?

Any help is greatly appreciated.

This looks to me like either:
a. bad md5sum
b. bad burn of the DVD as the DVD media is poor or the burn was done at too fast a speed, or
c. failing CD/DVD reader, or
d. failing CD/DVD burner.

I recommend you compare:
a. the md5sum listed on openSUSE Novell page for your DVD against …
b. the md5sum calculated from the .iso file of your downloaded DVD against …
c. the md5sum calculated on the burned DVD.
They should all be identical.

Our installation stickie gives links to help you with most of the above:
NEWBIES - Suse-11.0 Pre-installation – PLEASE READ - openSUSE Forums

I burned the image using K3b on my Kubuntu install (that I’m trying to replace with openSUSE). The MD5 sums checked out, but I’m cheap, so I’m not exactly using high quality DVDs :stuck_out_tongue: I’m re-downloading the ISO on a different PC, and I’ll burn it onto a different DVD.

I’ll let you know how it goes. Thanks for your help.

Can you amplify (provide more detail) re the above statement?

Did you check the md5sum of the burned DVD ?

OK, but if the md5sum of the downloaded iso file was good, why not copy it over via a USB stick (from your first download) and save yourself the bandwidth?

OK, I have now downloaded and burned the DVD ISO file three times. The first attempt is detailed above. I then switched to a different PC, a different DVD drive and different DVDs. The MD5 of the ISO was fine, and my burning app reported the data was burned correctly (and verified it after burning). However, the installer said there was an error with one of the sectors when I checked it.

So, third time: different PC again, different drive and yet another different DVD. MD5 of the ISO checks out, burns fine, and the integrity of the data is verified by the DVD burning app. This time, the installer doesn’t have a problem with any of the sectors, so I enter the actual installation. Surprise, surprise, another error:

Unable to create repository from URL ‘cd:///?devices=/dev/sr0’.

Valid metadata not found at specified URL(s).


  • Can’t copy /var/adm/mount/AP_0x00000001/media.1/media to /var/cache/zypp/raw/RepositoryREc5ky
  • Can’t provide /media.1/media : Can’t copy /var/adm/mount/AP_0x00000001/media.1/media to /var/cache/zypp/raw/RepositoryREc5ky

Try Again?

And at that point my installation is once again thwarted.

I am following all the advice for downloading and burning the DVD, but I’m having no luck. As the first installation wiped my hard drive before deciding it wouldn’t work, I’m stuck using a Kubuntu Live CD for the time being on my laptop. I can burn and read other DVDs perfectly well on all three machines, but it seems they just don’t like the openSUSE DVD…

I think this is because you can not create an error free DVD.

Try the approach recommended by Ken_Yap. This should work with a kubuntu live CD:
openSUSE Forums - View Single Post - DVD to ISO

To re-explain, open a konsole and run isoinfo on the file to get the number of blocks. E.g.

> isoinfo -i /dev/sr0 -d

Look for the line
Volume size is: XXXXXXX

Now in your konsole, cd to a directory on your hard drive (and not on the live CD). You need about 4GBytes of drive space for the following. …

Use this XXXXXXX value in a dd command (for example):
> dd if=/dev/sr0 of=image11.iso bs=2k count=XXXXXXX

That will create about a 4GByte image11.iso file on your hard drive.

Then run:
> md5sum image11.iso
and that will give you an md5sum that should match that of the openSUSE web site.

I get a 3.7Gb ISO file (3719593984 bytes (3.7 GB) copied, 1429.19 s, 2.6 MB/s).

The original ISO I burned the DVD from had the same MD5 sum as listed on the openSUSE website (ed6a5b3feb668866df812b1c2aed9d7f) but the ISO I just generated from it didn’t (cc92173de91eac5c47bca7eef28d3449). Despite my burning applications assuring me that the data was all burned correctly, I guess they’re just not thorough enough.

I’ve got a pile of half a dozen old DVD drives next to me. I’ll hook them up to a desktop and see if any of those drives will burn a decent DVD.

:nerd: I think the solution here is wrong. I use qualty writer and discs. I had a same problem but looks like the solution is in the reader side.
:’( Some of the old? DVD drive has problem to read full writed discs sometimes in server hardware. Maybe has problem to synchronize track if not enough empty track in! This disc always readable in new drives. In “old” drive sometime errorfree sometimes failed. For example the suse install disc check sometimes errorfree sometimes failed.
:sarcastic: So making the 4.3GByte install disk was not the best idea…

What solution are you refering to?? I just re-read the thread, and I don’t see a solution ! Nor do I recall giving a solution - the reason being I did not know of a solution. I did, though, have some ideas/suggestions.

Hence rather I see suggestions as to where the user could look to see if they could help localize where their problem might be. Again I don’t call that a solution.

I guess I am puzzled as to what solution are you referring to?

As for the means of doing a check sum. It works. I’ve tested it. BUT just because a CD passes a checksum, does not mean it will “work” for certain.

Contributions to help users with problems are always welcome in our forum, so if you have a solution, then by all means please post it. :slight_smile:

I also have discovered that the calibration between old drives and new drives can differ, and sometimes a DVD burned on an old drive will not work on a new drive, and the reverse is also true.

I had a similar issue and solved it with K3b settings. If you are currently not having a linux OS running you may see if your burn application offers following settings:

  • set the lowest awailable speed (1x) if possible
  • use in K3b the writing mode DAO
    For me this solved the problem. Seems that DVDs even if burned well are somehow less reliable when finished at high speed.
    Hope that works for you.