Repair dual boot with vista & openSUSE

Hi, i tried to follow your indications, but with the cfdisk I get this error:

ERROR MUY GRAVE: Partición primaria incorrecta 1: La partición termina en el último cilindro parcial

(FATAL ERROR: incorrect primary partition 1:partition ends in the last partial cilinder) Something like that should be the proper translation

What can I do now?

Here’s two questions:

  1. Can you ignore the error message and go ahead and set the bootable flag?
  2. The partition you are trying to set the flag on – is it a vista NTFS partition?

Hello, these are then answers:

  1. After that message, I just press a key and go back to the prompt.
  2. Yes, it is a vista NTFS partition.

Any additional information, just ask. I really appreciate all of your help.

The error message is not uncommon for NTFS created in vista – don’t worry about it. But it might interfere with setting the active flag using Linux.

Can you please run this additional console/terminal command and post back the results:

sudo /sbin/fdisk -l | egrep "'*'|sda1"

It’s easy to make a typo so perhaps copy and paste it into the window if you’re getting error messages. It will tell me which partition is set active/bootable and also the status of the NTFS partitions.

Ok, the result is:

/dev/sda1 1 7436 59721637 7 HPFS/NTFS
/dev/sda3 * 7436 10668 25968699+ f W95 Ext’d (LBA)

I’ll wait for your instructions. Thanks.

You haven’t told us what the problem is yet.

I’ll guess this:

  • When you boot using the hard drive, you get a Grub menu.
  • You can select openSUSE and it will boot to openSUSE OK.
  • Or you can select vista but the boot fails for vista.

Is that what happens? If that’s not what happens, please describe what the real problem is.

Hey sorry. What happens is that I want to “uninstall” opensuse from my laptop (reason? well, i’m going to buy a new one and the new user of the computer just want to have vista). So, I was looking for a save way to "uninstall"opensuse and I found this thread (well, the original one), but when I tried to follow the steps indicated I found the problem I drescribed when trying to change the (*) to the vista partition.
Hope I was clear enough, I’ll will be waiting for future indications and answers.

Easiest way IMO. Is Boot Parted Magic: Downloads - Parted Magic

Delete the Suse partitions, give the space back to windows and toggle the boot flag back to windows too.

Then you probably need to fix the Vista boot code (you’ll soon find out when you try and boot)
You need a dvd for vista. If you don’t have one. Look here: Windows Vista Recovery Disc Download — The NeoSmart Files

Read this:
Winhoes no longer likes to boot after fresh install - Page 4 - openSUSE Forums