repair bootloader in opensuse 11.3


I have made the mistake of installing windows XP on one of my drive after I’ve upgraded to opensuse 11.3 on my other drive. Now, my computer is always booting to XP and doesn’t load Grub anymore… I guess I should have seen it coming :smiley:
I previously had similar problems with my boot loader which I could resolve using the Repair boot loader utility distributed with the installation DVD. Apparently, this utility is not distributed anymore with opensuse 11.3… so I’m a little lost. I’d like a bit of advise before I start messing with Yast / boot loader and potentially break everything.

My system is setup as follows:

  • sda is partitioned into sda1 (swap), sda2 (root / in ext4), sd3 (/home in ext3) and sd4 (/windows/F in NTFS containing virtual machines)
  • sdb is partitioned into sdb1 (my Windows XP install in NTFS) and sdb2 (another storage drive in NTFS).

Thanks in advance


So, is your BIOS set to boot from /sda or sdb? I am wondering how Windows is working on /sdb if it is not the boot drive in your BIOS. Here is a tutorial on multi-booting which might be helpful.

GRUB Boot Multiboot openSUSE Windows (2000, XP, Vista) using the Grub bootloader.

You need to know which hard drive you are booting from. Grub can be loaded into the Master Boot Record (MBR) or loaded into the openSUSE partition, where the menu.lst file is located. Normally, I use a generic MBR and place Grub into the openSUSE partition which must be marked active for booting and included on the hard drive designated as the boot drive in your BIOS. I am just not sure what part of this is not messed up for you.

Thank You,

Usually you can fix it by booting into openSUSE e.g. with help from the install DVD and then running the Yast bootloader configurator to create a new entry that overwrites what the install of xp put in your Master Boot Record. See the link by jdmcdaniel3 or if that doesn’t do it for you try this link: HowTo Boot into openSUSE when it won’t Boot from the Grub Code on the Hard Drive and check the Appendix


According to the BIOS, sda (where opensuse is installed) should have priority over sdb (where windows is installed)… but still, my computer is booting to windows. Thank for the link, I’ll have a look at it.


I have read the content of the provided links… all pages assume that one can use the repair installed system from the installation DVD. This option is not available anymore in the opensuse 11.3 DVD. Any thougth on that? How could I Install a new boot loader without the DVD?


Problem solved thanks to the appendix in HowTo Boot into openSUSE when it won’t Boot from the Grub Code on the Hard Drive

Thanks Swerdna and jdmcdaniel3

Good to see, another success story for Linux.


I found the following link that shows how to fix your kernel with the opensuse 11.3 DVD it can also be used to re-install your bootloader (or at least it worked for me):
Picasa Web Albums - carl fletcher - DVD Kernel Fix

  1. Insert the DVD and reboot
  2. Choose Installation
  3. Choose Update
  4. Navigate through some windows until you reach the Installation Settings windows
  5. Click on packages
  6. Go to the Installation Summary Tab
  7. Click Packages > All in this list > keep
  8. Go to the search tab
  9. search for and re-install grub
  10. click accept and update
  11. reboot

Hope this helps