Removing installation USB messed up my LEAP 42.1 Operating System

Well, I didn’t think I would be back to the forum so soon. My system would not update unless I kept the installation USB plugged in. I thought that my removing it, it would force the system to go online for updates. But instead of that happening it sent my system into a freeze and now it will not boot. When I go into recovery mode, I end up with the non graphical system. Is it possible that someone could guide me through the recovery, or will I have to reinstall the system? Will it be necessary to keep the installation USB plugged in for the system to update? I am not sure what is happening here. Thanks in advance for any help that can be given.

Go to Yast Repository management and remove it from the repo list

I am now at a point where I have no control over the machine. When I turn on the machine it goes to output where the last few lines are as follows:

4.7506621] XFS (sda2): Corruption of in-memory data detected. Shutting down filesystem
4.7507651] XFS (sda2): Please umount the filesystem and rectify the problem(s)
Warning: Boot has failed. To debug this issue add “ rd.debug” to the kernel command line.

This is followed by a blinking cursor which will accept no input. How do I get to a command line from here? I am assuming I need a command line to run the zypper commands?

OK. I booted into rescue mode off the installation usb and now i am at a rescue root command. I attempted to run ‘zypper repos’ from here but I am in the bash shell. Where do I go from here? Thanks for your help.

From there, you can mount your root file system. Then go to: “/etc/zypp/repos.d” (relative to the mounted file system).

Find the file for that repo. It is probably named “openSUSE-42.1-0.repo”.

Use a text editor to change “enabled=1” to “enabled=0”.

However, that might not solve your immediate problem that has to do with the activity under way already.

I have decided to do a fresh install. If someone can give me an answer to the following question, I would appreciate it. When doing the first installation I checked on the option to have the repositories installed during the installation. Is this what caused the necessity of the usb to remain mounted to update my machine? If I do not check that option for the next install, I am thinking that I can download the repositories after my machine is up and running and then I will not have to keep the installation usb mounted? Am I thinking correctly here? Thanks.

No, that’s unrelated. The option that you checked was almost certainly to use the online repos during install. The purpose of doing that is to have access to software that is not on your USB. But it is probably wiser to install that later anyway.

The USB will show up as a repo no matter what.

When your system is up and running, start

Yast → Software Repositories

Look for the repo for your USB. It is probably called “openSUSE-42.1-0”, and the link for it will begin “hd:///”.

Select that line with the mouse. Then uncheck the “enabled” box. After that, it won’t look for the USB again.

OK I want to thank everybody who has tried to help me in the past few weeks. However, I have found the problem that is likely at the root cause of nearly all of the problems that I have experienced. I ran a memory test on both of my 4gb ram sticks. One stick has thousands of errors on it. Half of my memory was on the fritz. New memory is on the way.

Sometimes it is simple memory problem due to bad pin contacts. So try reseating that memory unit. That is, unplug it, then plug it back in. While plugging back in, gently wiggle it to make sure that it makes good electrical contact. Then repeat the memory test.

… also, in addition to the post just before this:

You can try cleaning the contacts on the memory stick by rubbing lightly with an eraser, see if that helps.:wink: