removing desktop effects

i have a SUSE 11.1 installed on my laptop, using VMware.
i accidentally turn on the desktop effects on the root user. then the screen went blank…
every time i log in as root a get a white sceern.
i have an access to the admin user.
is there anything i can do to disable the desktop effects at the root user?


assuming that you are using KDE 4,
pls login as another user/root in CLI,
disable the effect by editing the kwinrc file
located at ~/.kde4/share/config/


Btw, logging in as root is not a good practice,
you should log in as a normal user and use su or sudo instead.


first of all, thanks.
but I can’t find this directory (/.kde4), so I’m guessing I’m not using KDE…
Is there any other directory that I can try to find this file?

And I know it’s note a good practice to run as root, but must of the time I have to do so, in order to run the services that I need.

thanks again.

in order to run something as root you can do this from a normal user terminal:


then type in your root password,
and any command you run in the terminal will be run as root.

you just need to type exit to end the root session.

or you can use sudo from a terminal.

You can find out what Desktop Environment that you are using by clicking on the session type at the Login screen.

If you are using KDE4,
you should find the config file at:


to disable the desktop effect, please edit the
enabled=true to enabled=false
under the [compositing] section

Good luck

I’m using gnome.
what is the path for the config file?


Hi maayanm

Not a Gnome user, but try this: Navigate to Computer->More Applications->Desktop Effects, then uncheck ‘Enable Desktop Effects’

Hopefully that will work for you.

please edit /etc/X11/Xorg.conf

look for

Section "Extensions"
  Option "Composite" "on"

change it to “off”

restart your X server,
and do as what the previous post said

Good luck