Removing bold font from boot mesages

we are booting our hosts with “noplymouth” kernel option and watch boot messages via console with amt or ipmi.

After upgrading from SLE 15 SP2 to SP3 (i.e.opensuse 15.2 -> 15.3) the systemd messages are partially printer in bold font, i.e. they look like:
OK ] Stopped Create Volatile Files and Directories.
OK ] Stopped target Local File Systems.

On a serial console this make messages indeed more confusing and harder to read.

Does anyone know if there is a place where these escape codes for colors and bold print can be adjusted? I’m not sure if this formatting is done by systemd or by plymouth (which is needed for feeding the message to the serial console) and I couldn’t find any documentation about it so far.


Try “systemd.log_color=0” kernel command line option.

Thanks for your help! This option indeed removes all formatting, so colors, too. This is bad as seeing errors in red is definitely helpful. I’d like to remove the bold print only. As you have clarified that the behaviour is caused by systemd (and not plymouth) I should ask on the systemd list.