Removed Nvivia drivers to change to non-Nvidia card, but no X Windows

Hi all
I’m trying to replace my Nvidia card with an AMD card. I thought if I removed the Nvidia drivers, swapped the cards, then rebooted, the system would pick up the default driver. But boot terminates with unable to start X Windows. Can I do something to revert to the native drivers for the AMD card?


You may need to run mkinitrd to discover the new hardware. Also be sure you don’t have any NVIDIA configs in the /etc/X11/xorgconf file or any /etc/X11/xorgconf.d files.

Thanks! I should say I’m not familiar with any of this.

I ran mkinitrd.

The /etc/X11 directory contains files Xmodmap, Xmodmap.remote, Xresources, xim and xorg.conf.install,
and directories fs, lbxproxy, proxymngr, xdm, xim.d xinit, xorg.conf.d, and xsm.

The xorg.conf.d contains only 00-keyboard.conf

I’m still not able to start a window session and would really appreciate any further suggestions.

Thanks, Fred

Un-installation instructions provided among NVidia proprietary video driver installation instructions must be strictly followed for removal to succeed. In addition to configuration files their installation may change or create (e.g. those implied by gogalthorp’s response), NVidia’s driver packages routinely replace some library with its own that will not function with any competent FOSS X driver.

To possibly make it easier to work out how to get the purging accomplished, you may boot using the E key at the Grub menu to append nomodeset to the line beginning with linu before proceeding with boot. This should enable a reduced competence, low resolution X session to start.

If nomodeset remains on the linu line in your Grub menu subsequent to NVidia driver removal, it will block the modesetting DDX driver and the amdgpu DDX driver from being employed, disabling full resolution and functionality in X sessions. This could be why you’re getting no X session now.

If you

cat /proc/cmdline

you can see if nomodeset was employed on the current boot.

OK, so I looked at /proc/cmdline and saw nothing about nomodeset.
I then rebooted with nomodeset added at the end of the linux line, and got: ERROR VGACON disables amdgpu kernel modsetting.

That it does. Nomodeset is intended for assisting troubleshooting and facilitating the making of configuration corrections and utilizing package management.

Oh yes, right. I misunderstood, I get it now.

But I still have no idea how to proceed now.

Although, given what you said about the correct procedure for deinstallation of Nvidia, maybe I could just reinstall the Nvidia drivers from the command line and put the old video card back in. Assuming that worked I could then follow the deinstallation instructions properly.

OK, went ahead and did that, up and running again with the old Nvidia card.

So if someone could now point me to these detailed instructions about how to do all this properly? >:(

What instructions did you follow to install? Do they not include de-installation instructions?

Well I didn’t follow any instructions to install. Found the 15.2 repo for Nvidia and just went ahead with the install for my card version, and it all just worked. Kind of just assumed that laid-back approach would work with the uninstall too. :shame: But now I’ve found the SDB document for Nvidia and am all set.

Thanks again to all for your time and expertise.