Remove widget

I have fully updated Tumbleweed, using KDE and Plasma. I right-clicked on the desktop to bring up the menu and clicked on “add widgets.” I selected the web browser widget to have quick access to a favorite webpage.

The standard way to adjust a widget is to click and hold until the adjustment bars show up. This is not working. I even tried zypper dup with a reboot and still the problem persists. The widget is too small to display the webpage at a useful size. I cannot remove this widget, which is my preference. I tried accessing the widget from the widget menu that pops up when you click “add widget,” but that gives no way to adjust or remove the web page widget. Worse, it adds another instance of the same useless widget.

Please help me get rid of this thing!

Make sure that you’ve unlocked widgets before trying to remove (or alter) them. After that just right-click on the widget and remove it.

I did remember to unlock them. In fact, I locked them and then unlocked them to see if that would do the trick. It didn’t.

Are you saying that when you click on the red ‘x’ the widget is not removed? Not sure why that would be the case. However, you could remove it from the config file (~/.config/plasma-org.kde.plasma.desktop-appletsrc) directly I guess.

It will look something like this

[Containments][58][Applets][67]
immutability=1
plugin=org.kde.plasma.webbrowser

Once removed, the widget should be gone after next login.

To be clear: there were no handles of any kind; no red x, no sizing, no moving. I use two other desktop widgets: notes and weather. Hovering over either, with left mouse key depressed, will display the handles. So, the problem is web browser widget specific.

BUT, the coding worked!!! Thanks for helping get rid of that nuisance!

Not sure why that occurred. I tried it with no issues at all.

BUT, the coding worked!!! Thanks for helping get rid of that nuisance!

No worries, sometimes manual config edits get the job done more effectively! :slight_smile: